Программа по с++ информатика пожалуйста
Создайте структуру, описывающую точку в трехмерной системе координат (x, y, z). Найдите расстояние между двумя точками A(x1,y1,z1) и B (x1,y1,z1).
C/C++
помогите кто-то выражение для вычисления расстояния сделать ;(
Программа по с++ информатика пожалуйста ю

Илья Толмачёв
double distance = sqrt((first.x-second.x)*(first.x-second.x) + (first.y-second.y)*(first.y-second.y) + (first.z-second.z)*(first.z-second.z));
#include
#include
#include
using namespace std;
struct Point3d {
double x;
double y;
double z;
double length(const Point3d p)const {
return sqrt(pow(p.x - x, 2) + pow(p.y - y, 2) + pow(p.z - z, 2));
}
};
double coord(const string& msg) {
cout > value;
cin.ignore(0x1000, '\n');
return value;
}
Point3d point(const string& msg) {
Point3d p;
p.x = coord(msg + "x: ");
p.y = coord(msg + "y: ");
p.z = coord(msg + "z: ");
return p;
}
int main() {
const auto a = point("A");
const auto b = point("B");
const auto length = a.length(b);
cout
Так:
#include <cmath>
#include <iostream>
using namespace std;
struct point { double x, y, z; };
int main() { double x, y, z; point A, B;
cout << "A(x,y,z): "; cin >> A.x >> A.y >> A.z;
cout << "B(x,y,z): "; cin >> B.x >> B.y >> B.z;
x = A.x - B.x; y = A.y - B.y; z = A.z - B.z;
cout << "|AB| = " << sqrt(x * x + y * y + z * z); }
Или так:
#include <cmath>
#include <iostream>
using namespace std;
struct point { double x, y, z; };
point coord(char s) { cout << s << "(x,y,z): ";
point P; cin >> P.x >> P.y >> P.z; return P; }
int main() { double x, y, z; point A, B;
A = coord('A'); B = coord('B'); x = A.x - B.x;
y = A.y - B.y; z = A.z - B.z; cout << "|AB| = "
<< sqrt(x * x + y * y + z * z); }
#include <cmath>
#include <iostream>
using namespace std;
struct point { double x, y, z; };
int main() { double x, y, z; point A, B;
cout << "A(x,y,z): "; cin >> A.x >> A.y >> A.z;
cout << "B(x,y,z): "; cin >> B.x >> B.y >> B.z;
x = A.x - B.x; y = A.y - B.y; z = A.z - B.z;
cout << "|AB| = " << sqrt(x * x + y * y + z * z); }
Или так:
#include <cmath>
#include <iostream>
using namespace std;
struct point { double x, y, z; };
point coord(char s) { cout << s << "(x,y,z): ";
point P; cin >> P.x >> P.y >> P.z; return P; }
int main() { double x, y, z; point A, B;
A = coord('A'); B = coord('B'); x = A.x - B.x;
y = A.y - B.y; z = A.z - B.z; cout << "|AB| = "
<< sqrt(x * x + y * y + z * z); }
Похожие вопросы
- Циклический алгоритм. Составить программу на с++ Помогите, пожалуйста
- Надо написать программу на с++ СРОЧНО!!!!! ПОЖАЛУЙСТА
- Здравствуйте, не могу написать программу в С++, помогите пожалуйста.
- Информатика нужна программа
- Помогите пожалуйста написать программу на Си
- Помоги пожалуйста написать программу на C++
- Помоги пожалуйста с программой в С++
- Помогите пожалуйста написать программу на С++
- Помогите пожалуйста с программой
- Здравствуйте! Помогите, пожалуйста, с программой С++