(паскаль)
Программа целочисленно (без остатка) делит одно число на другое. Делимое генерируется случайно, оно должно быть пятизначное. Делитель вводит пользователь, на выбор: 1 или 2 или 3-х значный)
Домашние задания: Информатика
Срочно. Информатика 10 класс, написать программу
begin
var a := Random(10000, 99999): Integer;
WriteLn(a);
var b := ReadInteger;
a := a/b;
WriteLn(a)
end.
var a := Random(10000, 99999): Integer;
WriteLn(a);
var b := ReadInteger;
a := a/b;
WriteLn(a)
end.
Я немного понял задание: в смысле целочисленно? - Нет, я понимаю, конечно, что сие означает без остатка. Просто как именно сие реализовать именно целочисленно, т. е. с использованием div (и, естественно всё будет целым) или всё же более точно?
Вот именно целочисленно:
Program P1;
uses crt;
var a, b: integer;
begin
clrscr;
randomize;
a:=random (90000)+10000;
writeln ('Было сгенерировано число: ', a);
write ('Введите делитель (1-, 2- или 3-значное число): ');
readln (b);
if b>999 then write ('Ошибка: Вы ввели неправильный делитель. Программа завершена.') else write ('Ответ: ', a div b);
readkey;
end.
А вот более точный вариант (с округлением. Если без округления, то замените строку "c:=round (c);" на строку: "c:=trunc (c);"):
Program P1;
uses crt;
var a: integer;
b, c: real;
begin
clrscr;
randomize;
a:=random (90000)+10000;
writeln ('Было сгенерировано число: ', a);
write ('Введите делитель (1-, 2- или 3-значное число): ');
readln (b);
if b>999 then write ('Ошибка: Вы ввели неправильный делитель. Программа завершена.') else begin
c:=a/b;
c:=round (c);
write ('Ответ: ', c);
end;
readkey;
end.
Вот именно целочисленно:
Program P1;
uses crt;
var a, b: integer;
begin
clrscr;
randomize;
a:=random (90000)+10000;
writeln ('Было сгенерировано число: ', a);
write ('Введите делитель (1-, 2- или 3-значное число): ');
readln (b);
if b>999 then write ('Ошибка: Вы ввели неправильный делитель. Программа завершена.') else write ('Ответ: ', a div b);
readkey;
end.
А вот более точный вариант (с округлением. Если без округления, то замените строку "c:=round (c);" на строку: "c:=trunc (c);"):
Program P1;
uses crt;
var a: integer;
b, c: real;
begin
clrscr;
randomize;
a:=random (90000)+10000;
writeln ('Было сгенерировано число: ', a);
write ('Введите делитель (1-, 2- или 3-значное число): ');
readln (b);
if b>999 then write ('Ошибка: Вы ввели неправильный делитель. Программа завершена.') else begin
c:=a/b;
c:=round (c);
write ('Ответ: ', c);
end;
readkey;
end.
program dz2;
uses crt; {PascalABC}
Var n,a:integer;
label 1;
begin
1:write('wwedite 1,2,3-x znachn. chislo! a:='); read(a);
if (a<1) or (a>999) then goto 1;
randomize;
begin n:=random(90000)+10000;
writeln;
writeln('':3,n,'/',a,' = ',n/a);
end;
end.
uses crt; {PascalABC}
Var n,a:integer;
label 1;
begin
1:write('wwedite 1,2,3-x znachn. chislo! a:='); read(a);
if (a<1) or (a>999) then goto 1;
randomize;
begin n:=random(90000)+10000;
writeln;
writeln('':3,n,'/',a,' = ',n/a);
end;
end.
Похожие вопросы
- Информатика 10 класс
- Информатика 10 класс, помощь нужна срочно
- Информатика 10 класс. Паскаль
- ИНФОРМАТИКА 10 КЛАСС
- Информатика 10 класс
- Помогите пожалуйста!!! Очень срочно, информатика, 9 класс!!!
- СРОЧНО!!! ИНФОРМАТИКА 8 КЛАСС!!! ПОЖАЛУЙСТА!!!
- Информатика 10 класс Паскаль.
- Помогите пожалуйста!!! Информатика 10 класс Паскаль
- Информатика 10 класс Pascal