У меня установлен агент 6.0, могу я изменить его на версию 5.9 ?

Запросто. При установке на вопрос "Заменить? " выбираешь "Да".