Не могу поставить 64-битную Java

32-битная. вполне хватит. вам