Зд. 1Дан массив A(20). Найдите произведение отрицательных элементов массива и сумму положительных элементов массива.
Зд. 2Дан массив D(16). Найти сумму модулей отрицательных элементов и количество элементов равных нулю. 
Зд. 3Создайте массив B(К) из целых чисел вычисленных случайным образом и найдите сумму и произведение всех его нечетных элементов.
Зд. 4Дан массив А (20). Найдите количество элементов массива, которые при делении на семь дают в остатке три и выведите их на экран через запятую.
Зд. 5Элемента массива А вычисляются по формуле: A(i) =Sin(i / 100), где i = 1, 2, 3… . Напишите программу, которая находит сумму элементов массива А стоящих до первого отрицательного элемента. Сообщите номер и значение первого отрицательного элемента массива А.
	
	
	Домашние задания: Информатика
	
		
		
								
				
								
				
																				
							
			
	
		
			Информатика 10-11 класс Массивы Pascal1
1) Program P1;
uses crt;
const n=20;
var A: array [1..n] of real;
i: integer;
po, sump: real;
begin
textbackground (1);
textcolor (15);
clrscr;
po:=1;
sump:=0;
for i:=1 to n do begin
write ('Введите элемент массива: ');
readln (A[i]);
end;
for i:=1 to n do begin
if A[i]<0 then po:=po*A[i];
end;
for i:=1 to n do begin
if A[i]>0 then sump:=sump+A[i];
end;
write ('Произведение отрицательных элементов массива: ', po, ' Сумма положительных элементов массива: ', sump);
readkey;
end.
2) Program P2;
uses crt;
const n=16;
var D: array [1..n] of real;
i, kol: integer;
sum: real;
begin
textbackground (1);
textcolor (15);
clrscr;
kol:=0;
sum:=0;
for i:=1 to n do begin
write ('Введите элемент массива: ');
readln (D[i]);
end;
for i:=1 to n do begin
if D[i]=0 then kol:=kol+1;
end;
for i:=1 to n do begin
if D[i]<0 then sum:=sum+abs (D[i]);
end;
write ('Сумма модулей отрицательных элементов массива равна: ', sum, 'Количество 0-вых элементов массива составляет: ', sum);
readkey;
end.
3) Program P3;
uses crt;
const k=10;
var B: array [1..k] of integer;
i, p, sum: integer;
begin
textbackground (1);
textcolor (15);
clrscr;
p:=1;
sum:=0;
for i:=1 to k do begin
randomize;
B[i]:=random (100);
end;
for i:=1 to k do begin
if B[i] mod 2<>0 then begin
p:=p*B[i];
sum:=sum+B[i];
end;
end;
write ('Сумма нечетных элементов массива составляет: ', sum, ' Произведение нечетных элементов массива равно: ', p);
readkey;
end.
4) Program P4;
uses crt;
const n=20;
var A: array [1..n] of integer;
i, kol: integer;
begin
textbackground (1);
textcolor (15);
clrscr;
kol:=0;
for i:=1 to n do begin
write ('Введите элемент массива: ');
readln (A[i]);
end;
for i:=1 to n do begin
if A[i] mod 7=3 then kol:=kol+1;
end;
writeln ('Количество элементов массива, которые при делении на 7 дают в остатке 3, составляет: ', kol);
for i:=1 to n do begin
if A[i] mod 7=3 then begin
write (A[1], ', ', A[i]);
end;
end;
readkey;
end.
5) Здесь могу ошибаться, но вроде:
Program P5;
uses crt;
const n=100;
var A: array [1..n] of real;
i, pn: integer;
sum, z: real;
begin
textbackground (1);
textcolor (15);
clrscr;
sum:=0;
for i:=1 to n do begin
A[i]:=sin (i/100);
end;
for i:=1 to n do begin
while A[i]>=0 do begin
sum:=sum+A[i];
end;
end;
writeln ('Сумма элементов массива составляет: ', sum);
for i:=1 to n do begin
if A[i]<0 then begin
pn:=i;
z:=A[i];
writeln (pn, ' ', z);
end;
end;
readkey;
end.
				
							uses crt;
const n=20;
var A: array [1..n] of real;
i: integer;
po, sump: real;
begin
textbackground (1);
textcolor (15);
clrscr;
po:=1;
sump:=0;
for i:=1 to n do begin
write ('Введите элемент массива: ');
readln (A[i]);
end;
for i:=1 to n do begin
if A[i]<0 then po:=po*A[i];
end;
for i:=1 to n do begin
if A[i]>0 then sump:=sump+A[i];
end;
write ('Произведение отрицательных элементов массива: ', po, ' Сумма положительных элементов массива: ', sump);
readkey;
end.
2) Program P2;
uses crt;
const n=16;
var D: array [1..n] of real;
i, kol: integer;
sum: real;
begin
textbackground (1);
textcolor (15);
clrscr;
kol:=0;
sum:=0;
for i:=1 to n do begin
write ('Введите элемент массива: ');
readln (D[i]);
end;
for i:=1 to n do begin
if D[i]=0 then kol:=kol+1;
end;
for i:=1 to n do begin
if D[i]<0 then sum:=sum+abs (D[i]);
end;
write ('Сумма модулей отрицательных элементов массива равна: ', sum, 'Количество 0-вых элементов массива составляет: ', sum);
readkey;
end.
3) Program P3;
uses crt;
const k=10;
var B: array [1..k] of integer;
i, p, sum: integer;
begin
textbackground (1);
textcolor (15);
clrscr;
p:=1;
sum:=0;
for i:=1 to k do begin
randomize;
B[i]:=random (100);
end;
for i:=1 to k do begin
if B[i] mod 2<>0 then begin
p:=p*B[i];
sum:=sum+B[i];
end;
end;
write ('Сумма нечетных элементов массива составляет: ', sum, ' Произведение нечетных элементов массива равно: ', p);
readkey;
end.
4) Program P4;
uses crt;
const n=20;
var A: array [1..n] of integer;
i, kol: integer;
begin
textbackground (1);
textcolor (15);
clrscr;
kol:=0;
for i:=1 to n do begin
write ('Введите элемент массива: ');
readln (A[i]);
end;
for i:=1 to n do begin
if A[i] mod 7=3 then kol:=kol+1;
end;
writeln ('Количество элементов массива, которые при делении на 7 дают в остатке 3, составляет: ', kol);
for i:=1 to n do begin
if A[i] mod 7=3 then begin
write (A[1], ', ', A[i]);
end;
end;
readkey;
end.
5) Здесь могу ошибаться, но вроде:
Program P5;
uses crt;
const n=100;
var A: array [1..n] of real;
i, pn: integer;
sum, z: real;
begin
textbackground (1);
textcolor (15);
clrscr;
sum:=0;
for i:=1 to n do begin
A[i]:=sin (i/100);
end;
for i:=1 to n do begin
while A[i]>=0 do begin
sum:=sum+A[i];
end;
end;
writeln ('Сумма элементов массива составляет: ', sum);
for i:=1 to n do begin
if A[i]<0 then begin
pn:=i;
z:=A[i];
writeln (pn, ' ', z);
end;
end;
readkey;
end.
1).
Program massiv;
uses crt;
const n = 5;
var i,s,p: integer;
A:array [1..n] of integer;
begin
clrscr;
s:=0; p:=1;
writeln('':5,'wwedite elem. massiv!');
for i:=1 to n do begin
write('':5,'A[',i,'] = '); read(A[i]);
end;
for i:=1 to n do begin
if A[i]>0 then s:=s+A[i] else p:=p*A[i];
end;
writeln('':5,' summ pologh elem massiv: = ',s);
writeln('':5,' umnogh. otr elem massiv: = ',p);
readkey;
end.
				
									Program massiv;
uses crt;
const n = 5;
var i,s,p: integer;
A:array [1..n] of integer;
begin
clrscr;
s:=0; p:=1;
writeln('':5,'wwedite elem. massiv!');
for i:=1 to n do begin
write('':5,'A[',i,'] = '); read(A[i]);
end;
for i:=1 to n do begin
if A[i]>0 then s:=s+A[i] else p:=p*A[i];
end;
writeln('':5,' summ pologh elem massiv: = ',s);
writeln('':5,' umnogh. otr elem massiv: = ',p);
readkey;
end.
								
									Elona Alieva								
								Человеку, как я понимаю, нужен массив, состоящий из 20 элементов, а не из 5. Поэтому const n = 20 было бы верно.							
											Похожие вопросы
- сколько чисел находится между CD 16 и D4 16 информатика 10-11 класс
- Информатика 10-11 класс Паскаль
- 10-11 класс информатика, дайте решение, пожалуйста
- Помогите с темой индивидуального проекта 10-11 класс.
- Информатика 10 класс
- помогите с информатикой 11 класс
- Информатика, решение задач на массивы
- Информатика, решение задач на массивы. Прошу срочно!!!
- Информатика 10 класс. Паскаль
- ИНФОРМАТИКА 10 КЛАСС
 
			 
						