Вот задачи. Последние 4 однотипные, поэтому хотя бы с одной из них помогите, пожалуйста.
1) Найдите сумму цифр трёхзначного целого числа К
2)Дано расстояние в миллиметрах. Переведите это расстояние в сантиметры и миллиметры
3)Найдите произведение цифр трёхзначного целого положительного числа
4)Дана масса тела в граммах. Переведите эту массу в килограммы и граммы
5)Дано расстояние в метрах. Переведите это расстояние в километры и метры
Другие языки программирования и технологии
Умные люди есть тут?;)) ) Помогите, пожалуйста, с домашней работой по информатике. Нужно в Паскале составить алгоритм реш
Доброго времени суток.
Пусть n какое-то целое число. Тогда сумму и произведение его цифр можно найти так.
S := 0;
P := 1;
while n > 0 do begin
d := n mod 10; {выделяем младший разряд числа}
n := n div 10; {и отбрасываем его}
S := S + d; {сумма}
P := P * d; {произведение}
end;
Остальное сами.
По другим задачам. Подозреваю, что они тоже на применение операторов целочисленного деления и получения остатка от деления (div и mod). Подсказка: Если разделить миллиметры на 10, то получим сантиметры, остаток же от деления даст миллиметры, которых не хватило до полного сантиметра.
Удачи!
Пусть n какое-то целое число. Тогда сумму и произведение его цифр можно найти так.
S := 0;
P := 1;
while n > 0 do begin
d := n mod 10; {выделяем младший разряд числа}
n := n div 10; {и отбрасываем его}
S := S + d; {сумма}
P := P * d; {произведение}
end;
Остальное сами.
По другим задачам. Подозреваю, что они тоже на применение операторов целочисленного деления и получения остатка от деления (div и mod). Подсказка: Если разделить миллиметры на 10, то получим сантиметры, остаток же от деления даст миллиметры, которых не хватило до полного сантиметра.
Удачи!
Данил Жданков
Спасибо большое! Надеюсь, получится)))
Помогать неучам - не признак ума.
Данил Жданков
Во-первых, я не неуч. А во-вторых, я не просила вопрос комментировать.
2) Миллиметры разделить на 10, получишь дробное число в сантиметрах
4) Граммы разделить на 1000 получишь дробное число в килограммах
5) Метры делишь на 1000 получаешь дробное число в километрах
1) x:=0 берешь от числа по одной цифре и прибавляешь это к переменной x
3) x:=1берешь от числа по одной цифре и умножаешь это на переменную x
4) Граммы разделить на 1000 получишь дробное число в килограммах
5) Метры делишь на 1000 получаешь дробное число в километрах
1) x:=0 берешь от числа по одной цифре и прибавляешь это к переменной x
3) x:=1берешь от числа по одной цифре и умножаешь это на переменную x
А мы по-старому:
for x:=1 to length(str(k)) do
s:=s+val(s);
write(s);
Ну, думаю, с типами и синтаксисом разберетесь!
for x:=1 to length(str(k)) do
s:=s+val(s);
write(s);
Ну, думаю, с типами и синтаксисом разберетесь!
если 1 на pascal писать, то самое легкое для понимания решение - 3х значное число можно перевести в строку, перебрать строку от 1 элемента к 3, к какой-то переменной прибавлять N элемент строки переведенный в числу
Данил Жданков
для меня сложновато...))
дойдёт только если всё конкретно подробно написать=)
дойдёт только если всё конкретно подробно написать=)
Похожие вопросы
- Помогите пожалуйста разобраться с вопросами по информатике и программированию
- помогите решить задачи с циклом по информатике в программе паскаль
- Всем добрый вечер! Помогите пожалуйста решить данную задачу по информатике.
- Помогите пожалуйста решить задачку на С++ очень нужно (((
- Помогите пожалуйста! Лучший ответ конечно будет отблагодарён!!!!Нужно взломать Rar архив любым способом!
- Помогите пожалуйста. Язык Си работа с файлами
- Информатика. Программирование. Обработка массивов данных. Помогите составить алгоритм и прог. код к нему.
- Написать программу в Паскале для построения графика функций. К программе желательно составить алгоритм.
- Помогите, пожалуйста... Курс информатики, 9 класс. В паскале вообще ничего не понимаю((
- Информатика.Практическая работа по паскалю.ПОМОГИТЕ.Все нужно ввиде паскаля.мучаюсь целый день.постоянно какие-то ошибки