Другие языки программирования и технологии

Информатика.Практическая работа по паскалю.ПОМОГИТЕ.Все нужно ввиде паскаля.мучаюсь целый день.постоянно какие-то ошибки

Составьте программу расчета скорости движения V в скважине с

производительностью Q насоса и площадью поперечного сечения F скважины.

Математическая формулировка задачи. Скорость движения раствора определяется по

формуле V = Q/F, где Q — производительность насоса; F — площадь поперечного

сечения кольцевого пространства между стенками скважины и бурильными трубами.

Площадь сечения скважины F1 = π*D1*D1 /4; площадь сечения бурильной трубы F2 =

π*D2*D2 /4 . Тогда F = F1-F2 Алгоритм решения задачи:

1. Ввод исходных данных D1,D2,Q;

2. Вычисление F1,F2,F и V;

3. Вывод результатов V
2.задача-Среднее арифметическое двух чисел равно половине

суммы этих чисел. Составьте программу, в которой вводится два

числа и вычисляется их среднее арифметическое
3.задача-Составьте программу, которая:

1. умножает это число на себя; складывает результат умножения с удвоенным

исходным числом;

2. делит полученную сумму на исходное число;

3. вычитает из результата деления исходное число;

4. выводит на экран окончательный результат.
Sungat Kommunar
Sungat Kommunar
127
Ахуеть... думал паскаль деградировал в дельфи... а оно вот оно чо
Сергей Ковалёв
Сергей Ковалёв
68 840
Лучший ответ
Андрей Шумский Автору вопроса - так а хде попытки?
>мучаюсь целый день.постоянно какие-то ошибки
Ну так показывай код, показывай ошибки - поправим.
Малик Рамазан
Малик Рамазан
76 061
"мучаюсь целый день.постоянно какие-то ошибки"?!
Вот для примера вторая программа:

var x,y:real; begin readln(x,y); writeln((x+y)/2); end.

"Хозяин садится в кресло, не отрывая восхищенного взора от книг. Затем он пододвигает к себе одну из них и начинает изучать ее. Брови его сдвинуты и губы шевелятся от усилий -
" Шесть, маленькое два сверху, крестик и закорючка.""
(Уэллс, "Человек-невидимка")
ИС
Иван Суслов
60 758
Андрей Журавлевич надо быть современнее
" - Получается удивительно интересная вещь, ребята! Помните закон Дега?
- Помним, - сказал Матти. - Секанс в степени две трети. "
Программы обозначаю как P1 (Program P1;), P2 и P3. Соответственно P1 - к 1-ому заданию, P2 - ко 2-ому, а P3 - к 3-му. Т.к. ответы от майл любят "съедать" часть кода в целях оптимизации, то в ответе напишу 1-ую программу, а остальные см. в комментариях к этому ответу.

Итак:

№1.

Program P1;
uses crt;
var D1, D2, F, F1, F2, Q, V: real;
begin
clrscr;
write ('Введите диаметр скважины (число), после чего нажмите клавишу Enter: ');
readln (D1);
if D1<=0 then writeln ('Ошибка: указан некорректный диаметр скважины.') else begin
write ('Введите диаметр бурильной трубы (число), после чего нажмите клавишу Enter: ');
readln (D2);
if D2<=0 then writeln ('Ошибка: указан некорректный диаметр бурильной трубы.') else begin
write ('Введите производительность насоса (число), после чего нажмите клавишу Enter: ');
readln (Q);
F1:=pi*sqr (D1)/4;
F2:=pi*sqr (D2)/4;
F:=F1-F2;
if F=0 then writeln ('Ошибка: происходит деление на 0.') else begin
V:=Q/F;
writeln ('Ответ: Скорость движения потока воды составляет: ', V);
end;
end;
end;
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
Александр Сотник №2.

Program P2;
uses crt;
var a, b: real;
begin
clrscr;
writeln ('Эта программа вычисляет среднее арифметическое 2 чисел.');
write ('Введите 1-ое число, после чего нажмите клавишу Enter: ');
readln (a);
write ('Введите 2-ое число, после чего нажмите клавишу Enter: ');
readln (b);
writeln ('Ответ: Среднее арифметическое чисел ', a, ' и ', b, 'составляет: ', (a+b)/2);
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
Александр Сотник №3.

Program P3;
uses crt;
var a, ch, r, s : real;
begin
clrscr;
write ('Введите число, после чего нажмите клавишу Enter: ');
readln (a);
s:=sqr (a)+2*a;
ch:=s/a;
r:=ch-a;
writeln ('Ответ: ', r);
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.

Похожие вопросы