Другие языки программирования и технологии
Информатика. 1 курс. Задачи. Решитья. Я в этом деле нуб.
Написать программу которая прверяет какое число встречается раньше положительное или отрицательное. Учесть что в начале массива могут стоять нулевые элементы
госпожа Отважная, Вам какой язык программирования-то нужен?)) )
Что java на первом курсе - это я сомневаюсь) )
если паскаль или си - напиши в комментах - решу, задача простенькая))
Что java на первом курсе - это я сомневаюсь) )
если паскаль или си - напиши в комментах - решу, задача простенькая))
Андрей Е
Паскаль
Олег Носов
У меня есть Java на 1-ом...
import java.util.Scanner;
import java.util.Random;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
System.out.println("Введите размер массива");
int [] arry = new int [ scan.nextInt() ];
arry = fill(arry.length);
int notnull=0,count = 1;
System.out.print("Первый элемент ");
if (arry[ 0 ] < 0) System.out.print("- отрицательный. ");
else if(arry [ 0 ] > 0) System.out.print("- положительный. ");
else
if (arry[ 0 ] == 0) {
System.out.println("равен нулю, берем следующий элемент. ");
do {
if (arry[ count ]==0) { count++; System.out.println("Следующий элемент также равен нулю, "
+ " продолжаем поиск... ");}
else notnull = arry[ count ];
}while (notnull == 0);
System.out.print("Первый ненулевой элемент под номером " + count);
if(notnull < 0) System.out.println(" - отрицателен. ");
else if (notnull > 0) System.out.println(" - положителен. ");
}
}
public static int [] fill (int b){
Random gen = new Random();
int [] a = new int[ b ];
for (int i = 0; i < b; i++) a[ i ] = gen.nextInt(-5,10);
return a;
}
/******************************************************/
/****************Вывод*****************************/
/*
debug:
Введите размер массива
4
Первый элемент равен нулю, берем следующий элемент.
Следующий элемент также равен нулю, продолжаем поиск.. .
Следующий элемент также равен нулю, продолжаем поиск.. .
Первый ненулевой элемент под номером 3 - положителен.
BUILD SUCCESSFUL (total time: 1 second)
* */
import java.util.Random;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
System.out.println("Введите размер массива");
int [] arry = new int [ scan.nextInt() ];
arry = fill(arry.length);
int notnull=0,count = 1;
System.out.print("Первый элемент ");
if (arry[ 0 ] < 0) System.out.print("- отрицательный. ");
else if(arry [ 0 ] > 0) System.out.print("- положительный. ");
else
if (arry[ 0 ] == 0) {
System.out.println("равен нулю, берем следующий элемент. ");
do {
if (arry[ count ]==0) { count++; System.out.println("Следующий элемент также равен нулю, "
+ " продолжаем поиск... ");}
else notnull = arry[ count ];
}while (notnull == 0);
System.out.print("Первый ненулевой элемент под номером " + count);
if(notnull < 0) System.out.println(" - отрицателен. ");
else if (notnull > 0) System.out.println(" - положителен. ");
}
}
public static int [] fill (int b){
Random gen = new Random();
int [] a = new int[ b ];
for (int i = 0; i < b; i++) a[ i ] = gen.nextInt(-5,10);
return a;
}
/******************************************************/
/****************Вывод*****************************/
/*
debug:
Введите размер массива
4
Первый элемент равен нулю, берем следующий элемент.
Следующий элемент также равен нулю, продолжаем поиск.. .
Следующий элемент также равен нулю, продолжаем поиск.. .
Первый ненулевой элемент под номером 3 - положителен.
BUILD SUCCESSFUL (total time: 1 second)
* */
Марсель Зиннатов
сами писали?)))
Похожие вопросы
- Задача по Паскалю (1 курс)
- Что нужно знать на 1 курсе программирования в вузе? Чему учат на 1 курсе?
- При вызове Диспетчера задач выходит окошко: Диспетчер задач отключен администратором! Как исправить дело?
- Стоит ли уходить с Универа если я не вытягиваю и это мягко сказано. 1 курс учусь на программиста.
- си. для начинающих. 1 курс.
- Программирование. 1 курс.
- C++, программирование, 1 курс.
- С++ Арифметические действия над числами пронумерованы следующим образом : 1-сложение, 2-вычитание, 3-умножение, 4-дел...
- Объясните, пожалуйста, как решить задачу по информатике...
- Информатика. Помощь в решении задач по массивам