Школы
Информатика паскаль
1) Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 6 файлов в байтах (от 100 до 2000) и вычисляет: а) суммарный размер файлов в килобайтах б) средний размер файла 2) Составьте программу , которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечётных чисел б) сумму чисел, не превышающих 10 в) сумму чисел кратных 3 На экран выводятся исходные значения и результаты вычислений.
Вторая задача.. .
uses crt;
const
N=20; {размер масива}
type
ARR = array [0..N] of Integer;
var
i,res,k: Integer;
a,b: ARR;
begin
clrscr;
randomize;
{Наполняем массив A случайными числами, массив В значением False}
for i:=1 to N do a:=random(40);
{Выводим массив на экран}
WriteLn('Дан целочисленный массив: ');
Write('a[');
for i:=1 to N do Write(a,' ');
WriteLn(']');
Write('(Для продолжения нажмите Enter)');
ReadLn;
WriteLn('Находим среднее арифметическое нечетных чисел. ');
{Находим и выводим нечетные числа на экран}
res:=0;
k:=0;
WriteLn('Находим все нечетные числа: ');
for i:=1 to N do
begin
if odd(a) then
begin
Write(a,' ');
res:=res+a;
inc(k);
end;
end;
WriteLn;
WriteLn('Среднее арифметическое: ', (res/k):4:2);
Write('(Для продолжения нажмите Enter)');
ReadLn;
{Находим все числа, не превышающие 10, выводим их на экран и подсчитываем
ихнюю сумму}
Write('Находим числа, не превышающие 10: ');
res:=0;
for i:=1 to N do
begin
if a<=10 then
begin
Write(a,' ');
res:=res+a;
end;
end;
if res=0 then Write ('Таких чисел нет : ( ')
else
begin
WriteLn;
Write('Сумма чисел: ', res);
end;
WriteLn;
Write('(Для продолжения нажмите Enter)');
ReadLn;
{Находим все числа кратные трем и их сумму}
Write('Все числа массива кратные 3: ');
res:=0;
for i:=1 to N do
if (a<>0) and (a mod 3 = 0) then
begin
Write(a,' ');
res:=res+a;
end;
if res=0 then WriteLn('Таких чисел нет : (')
else
begin
WriteLn;
WriteLn('Сумма чисел кратных 3: ', res);
end;
Write('(Для выхода нажмите Enter)');
ReadLn;
end.
uses crt;
const
N=20; {размер масива}
type
ARR = array [0..N] of Integer;
var
i,res,k: Integer;
a,b: ARR;
begin
clrscr;
randomize;
{Наполняем массив A случайными числами, массив В значением False}
for i:=1 to N do a:=random(40);
{Выводим массив на экран}
WriteLn('Дан целочисленный массив: ');
Write('a[');
for i:=1 to N do Write(a,' ');
WriteLn(']');
Write('(Для продолжения нажмите Enter)');
ReadLn;
WriteLn('Находим среднее арифметическое нечетных чисел. ');
{Находим и выводим нечетные числа на экран}
res:=0;
k:=0;
WriteLn('Находим все нечетные числа: ');
for i:=1 to N do
begin
if odd(a) then
begin
Write(a,' ');
res:=res+a;
inc(k);
end;
end;
WriteLn;
WriteLn('Среднее арифметическое: ', (res/k):4:2);
Write('(Для продолжения нажмите Enter)');
ReadLn;
{Находим все числа, не превышающие 10, выводим их на экран и подсчитываем
ихнюю сумму}
Write('Находим числа, не превышающие 10: ');
res:=0;
for i:=1 to N do
begin
if a<=10 then
begin
Write(a,' ');
res:=res+a;
end;
end;
if res=0 then Write ('Таких чисел нет : ( ')
else
begin
WriteLn;
Write('Сумма чисел: ', res);
end;
WriteLn;
Write('(Для продолжения нажмите Enter)');
ReadLn;
{Находим все числа кратные трем и их сумму}
Write('Все числа массива кратные 3: ');
res:=0;
for i:=1 to N do
if (a<>0) and (a mod 3 = 0) then
begin
Write(a,' ');
res:=res+a;
end;
if res=0 then WriteLn('Таких чисел нет : (')
else
begin
WriteLn;
WriteLn('Сумма чисел кратных 3: ', res);
end;
Write('(Для выхода нажмите Enter)');
ReadLn;
end.
Чёто у меня сомнения что кто-то на халяву будет тебе эти проги писать.
Лучше найди у себя в школе какого-то програмера пригласи его домой угости пивом или чего он там любит, может он тебе чего и накрапает.
Лучше найди у себя в школе какого-то програмера пригласи его домой угости пивом или чего он там любит, может он тебе чего и накрапает.
Похожие вопросы
- Училка информатики ламер
- Все ли учителя информатики тупые
- о учителе информатики
- про учителя информатики
- Каков прядок проведения ЕГЭ по информатике??? или всё о ЕГЭ по информатике..
- Сложно ли сдавать ГИА по обществознанию и информатике?
- С какого класса в школах должны преподавать информатику?
- Стоит ли сдавать информатику на гуманитарном уклоне в 11 классе?
- Что нужно учить чтобы сдать ОГЭ (экзамен в 9 классе) по информатике?
- Как ответить учителю что я нехочу заниматься информатикой