«Какой твой любимый предмет, какую оценку ты по нему имеешь?» 
(Необходимо ввести предмет (словом), оценку)
	
	
	Домашние задания: Информатика
	
		
		
								
				
			
	
		
			Написать диалоговую программу, которая спрашивает у вас: «Какой твой любимый предмет, какую оценку ты по нему имеешь?»
Программу, значит, написать... - Это можно. Только вот на каком языке программирования это нужно сделать? - Нет, программе-то без разницы, на каком языке программирования она написана (из порядка 40 существующих), а вот учитель/преподаватель может спросить, с чего это вдруг программа написана на этом языке программирования, а не на том, который он(а) преподает. 
 
Единственное, что условие странное - ну да, программа спрашивает, пользователь отвечает. А дальше что программа делает с этими ответами? Просто, получив ответы, заканчивается, или выводит на экран сообщение типа "Значит, Ваш любимый предмет - {предмет, введённый пользователем}, Вы его расцениваете на {количество баллов}."?
 
Ладно, напишу оба варианта:
 
1) Программа сразу завершается - типа опросник такой:
				
							Единственное, что условие странное - ну да, программа спрашивает, пользователь отвечает. А дальше что программа делает с этими ответами? Просто, получив ответы, заканчивается, или выводит на экран сообщение типа "Значит, Ваш любимый предмет - {предмет, введённый пользователем}, Вы его расцениваете на {количество баллов}."?
Ладно, напишу оба варианта:
1) Программа сразу завершается - типа опросник такой:
 Program P1;  
uses crt;  
var o: real;  
    p: string;  
begin  
clrscr;  
writeln ('Ответы вводите с клавиатуры. После ответа на каждый вопрос нажимайте клавишу Enter.');  
writeln ('1-ый вопрос: Какой Ваш любимый предмет?'); 
write ('Ваш ответ: ');  
readln (p);  
writeln ('2-ой вопрос: На сколько баллов Вы его оцениваете в своем рейтинге?'); 
write ('Ваш ответ: ');  
readln (o);  
write ('Программа завершена. Для выхода нажмите клавишу Enter.');  
readkey;  
end. 2-ой вариант - "с подведением итогов": Program P1;   
uses crt;   
var o: real;   
    p: string;   
begin   
clrscr;   
writeln ('Ответы вводите с клавиатуры. После ответа на каждый вопрос нажимайте клавишу Enter.');   
writeln ('1-ый вопрос: Какой Ваш любимый предмет?');  
write ('Ваш ответ: ');   
readln (p);   
writeln ('2-ой вопрос: На сколько баллов Вы его оцениваете в своем рейтинге?');  
write ('Ваш ответ: ');   
readln (o); 
writeln ('Значит, Ваш любимый предмет - ', p, '. Вы его оцениваете на ', o, ' баллов в своем рейтинге.');  
write ('Программа завершена. Для выхода нажмите клавишу Enter.');   
readkey;   
end. P.S. можно обе переменные сделать типа string.Похожие вопросы
- Написать диалоговую программу, которая спрашивает у вас: «Какой твой любимый предмет, какую оценку ты по нему имеешь?».
- Написать диалоговую программу, которая спрашивает у вас: «Какая сегодня дата?»
- Напишите программу которая с помощью цикла For-NEXT выводит на экран рисунок «Крылья»
- 8 класс напишите две программы, используя цикл for
- Напишите, пожалуйста программу на языке раскаль Pascal ABC
- Напишите программу, которая в последовательности целых чисел определяет их количество и сумма четных чисел
- Напишите программу, которая вычисляет квадрат наименьшего из четырёх чисел
- Напишите программу которая вычисляет SS=(a+b+a)/(a*b*b)
- Помогите на Pascal сделать программу, которая считает количество дней до лета.
- Напишите код программы для решения данной задачи.
