Задание 1
 
Составьте блок-схему алгоритма для решения следующей задачи. 
 
Катет прямоугольного треугольника равен 5 см, а разность между гипотенузой и вторым катетом – 1 см. Вычислите площадь треугольника. 
 
Задание 2
Напишите программный код на языке Паскаль  для решения задания1.
Входные данные нужно задать путём ввода с клавиатуры. Предусмотрите проверку ввода нулевых значений.
	
	
	Домашние задания: Информатика
	
		
		
								
				
																				
							
								
				
				
							
			
	
		
			Помогите с информатикой срочно! блок схемы, паскаль
Задание 1: 
 
1. Задать значения катета и разности между гипотенузой и вторым катетом.
2. Вычислить гипотенузу треугольника по формуле: a^2 + b^2 = c^2.
3. Вычислить второй катет треугольника, вычитая разность между гипотенузой и вторым катетом из гипотенузы.
4. Вычислить площадь треугольника по формуле: S = (a * b) / 2.
5. Вывести результат на экран.
 
Блок-схема:
 
[задать значения катета и разности между гипотенузой и вторым катетом] -> [вычислить гипотенузу] -> [вычислить второй катет] -> [вычислить площадь треугольника] -> [вывести результат на экран]
 
Задание 2:
 
				
									1. Задать значения катета и разности между гипотенузой и вторым катетом.
2. Вычислить гипотенузу треугольника по формуле: a^2 + b^2 = c^2.
3. Вычислить второй катет треугольника, вычитая разность между гипотенузой и вторым катетом из гипотенузы.
4. Вычислить площадь треугольника по формуле: S = (a * b) / 2.
5. Вывести результат на экран.
Блок-схема:
[задать значения катета и разности между гипотенузой и вторым катетом] -> [вычислить гипотенузу] -> [вычислить второй катет] -> [вычислить площадь треугольника] -> [вывести результат на экран]
Задание 2:
 program TriangleArea;  
 
  
 
var  
 
  a, b, c, S: real;  
 
  
 
begin  
 
  writeln('Введите значение катета:');  
 
  readln(a);  
 
  writeln('Введите значение разности между гипотенузой и вторым катетом:');  
 
  readln(b);  
 
    
 
  if (a = 0) or (b = 0) then // проверка на нулевые значения  
 
    writeln('Некорректный ввод!')  
 
  else begin  
 
    c := sqrt(a*a + (b+1)*(b+1)); // вычисление гипотенузы  
 
    b := c - b - 1; // вычисление второго катета  
 
    S := (a * b) / 2; // вычисление площади треугольника  
 
    writeln('Площадь треугольника равна ', S:0:2, ' кв. см.');  
 
  end;  
 
end. 
								
									Алексей Натыньчик								
								Спасибо вам большое! Спасли!							
																				
								
									Нурлан Макашев								
								Зачем вводить разность с клавиатуры, если она и так в задании указана?							
																				
								
									Бэлла Нагоева								
								Огромное спасибо, вы просто меня спасли!							
											 Program S1; 
uses crt; 
var b, c: real; 
begin 
clrscr; 
writeln ('Введите с клавиатуры значения 2-ого катета и гипотенузы треугольника (только числа). После ввода каждого значения нажимайте клавишу Enter. При вводе дробных значений целую часть от дробной отделяйте точкой, а не запятой.'); 
write ('Введите значение 2-ого катета: '); 
readln (b); 
if bПохожие вопросы
- Помогите с информатикой СРОЧНО
- Помогите с информатикой срочно
- Пожалуйста помогите с информатикой, срочно
- Пожалуйста помогите с информатикой срочно!!!!!!
- Информатика, блок схема
- ПОМОГИТЕ !!!!ИНФОРМАТИКА СРОЧНО!!! ПАСКАЛЬ
- Информатика, блок схемы и программы
- Информатика. Тема: Составление блок-схем алгоритмов.
- Помогите с информатикой (паскаль)
- Помогите пожалуйста!!! Информатика 10 класс Паскаль
 
			 
						