Помогите, пожалуйста, написать программу.
Дан массив X(N). Определить произведение положительных элементов массива.
	
	
	Домашние задания: Информатика
	
		
		
								
				
																				
							
								
				
Вот ввод с клавиатуры:
				
							
								
				
																				
							
			
	
		
			Информатика, блок схемы и программы
Ай, ёпрст, прочитал как "в питоне". Не, тут я бессилен)
Это на ЕГЭ такое дают?)
Ну, если без ввода-вывода, то вот так:
				
									Это на ЕГЭ такое дают?)
Ну, если без ввода-вывода, то вот так:
 X = [12,-4,-5,-987654321,40,1,0,0,0,5,-1,4] 
 
mlt = 1 
for num in X: 
    if (num > 0): 
        mlt *= num 
 
print(mlt) 
								
									Евгений )))								
								Это в универе такое дают)							
											Дан массив X(N)В каком смысле? Если как константа, то где его значения? Он вводится вручную с клавиатуры? Или же, быть может, заполняется автоматически при помощи генератора случайных чисел?
Вот ввод с клавиатуры:
 Program P1; 
uses crt; 
const n=5; 
type mas=array [1..n] of real; 
var i: byte; 
    p: real; 
    x: mas; 
begin 
clrscr; 
p:=1; 
writeln ('Введите массив с клавиатуры (заполните числами). После ввода каждого из чисел нажимайте клавишу Enter. При вводе дробных значений целую часть от дробной отделяйте точкой, а не запятой.'); 
for i:=1 to n do begin 
write ('Введите ', i, '-й элемент массива: '); 
readln (x[i]); 
end; 
for i:=1 to n do if x[i]>0 then p:=p*x[i]; 
writeln ('Произведение положительных элементов массива: ', p :0:2); 
write ('Программа завершена. Для выхода нажмите клавишу Enter.'); 
readkey; 
end. Автоматическое заполнение при помощи генератора случайных чисел: Program P1; 
uses crt; 
const n=10; 
type mas=array [1..n] of integer; 
var i: byte; 
    p: integer; 
    x: mas; 
begin 
clrscr; 
p:=1; 
randomize; 
for i:=1 to n do x[i]:=random (21)-10; 
write ('Был сгенерирован массив: '); 
for i:=1 to n do write (' ', x[i]); 
writeln (' '); 
for i:=1 to n do if x[i]>0 then p:=p*x[i]; 
writeln ('Произведение положительных элементов массива: ', p); 
write ('Программа завершена. Для выхода нажмите клавишу Enter.'); 
readkey; 
end. А на чём написать программу C#?
				
									
								
									Екатерина Ежова								
								Подождите часа 2 я вам напишу							
																				
								
									Екатерина Ежова								
								Вот
var
a : array of integer := (12,-4,-5,-987,40,1,0,0,0,5);
mlt : integer;
begin
mlt:=1;
  
foreach num: integer in a do
begin
if (num > 0) then
mlt *= num;
end;
print(mlt);
end.
																				var
a : array of integer := (12,-4,-5,-987,40,1,0,0,0,5);
mlt : integer;
begin
mlt:=1;
foreach num: integer in a do
begin
if (num > 0) then
mlt *= num;
end;
print(mlt);
end.
								
									Екатерина Ежова								
								Это число равно 2400 для массива     (12,-4,-5,-987,40,1,0,0,0,5)							
											Похожие вопросы
- Информатика, блок схема
- Помогите с информатикой срочно! блок схемы, паскаль
- Информатика. Тема: Составление блок-схем алгоритмов.
- Срочно. Информатика 10 класс, написать программу
- Программа по информатике
- Прочитайте фрагменты программ, определите чему равно значение «c». Информатика. 8 класс. Как решать?
- Информатика 9 класс
- Помогите с информатикой, составить программу
- Информатика 8 класс программа кумир
- помогите с информатикой 11 класс
 
						