Домашние задания: Информатика

Помогите с информатикой, составить программу

Найти номер первой из строк прямоугольной матрицы, не содержащих ни одного отрицательного элемента (процедуры и функции тема)
// Поиск строки без отрицательных элементов
program Nika;

var
mtx: array[,] of shortint;
min, max: shortint;
str, col: byte;

begin
randomize;
write('Введите через пробел размерность матрицы (строк столцов): ');
readln(str, col);
setLength(mtx, str, col); // Размер матрицы
write('Введите через пробел мин. и макс. значения элементов: ');
readln(min, max);
for var i := 0 to length(mtx, 0) - 1 do begin // Строки
for var j := 0 to length(mtx, 1) - 1 do begin // Столбцы
mtx[i,j] := random(min, max); // Заполнение
write(mtx[i,j]:5); // Вывод
end; // for j
write(#10); // Новая строка
end; // for i
for var i := 0 to length(mtx, 0) - 1 do // Строки
for var j := 0 to length(mtx, 1) - 1 do // Столбцы
if mtx[i,j] < 0 then
break // Следующая строка
else
if j = length(mtx, 1) - 1 then begin
write('Номер первой из строк без отрицательных элементов: ', i + 1);
exit; // Строка найдена, конец
end; // if j
writeln('Во всех строках есть отрицательный элемент.');
end.
Серик Джусупов
Серик Джусупов
18 091
Лучший ответ
Серик Джусупов Введите через пробел размерность матрицы (строк столцов): 3 5
Введите через пробел мин. и макс. значения элементов: -2 4
3 4 1 -2 1
0 0 1 3 2
4 0 -1 3 -2
Номер первой из строк без отрицательных элементов: 2
Коротков Сергей только в обычном паскале не проканало значит это для pascal abc
public class Program{
public static void main(){
int[][] lines = new int[3][5]; //матрица 3х5, предположим.
lines[0] = {0,1,2,3,-4};
lines[1] = {0,1,2,3,4};
lines[2] = {0,1,-2,3,4};
//Заполнили линии и дальше сам обработчик
bool flag = false;
int i = -1;
do{

i++;
foreach(int integer in lines[i]){

if(integer < 0){
flag = false;
break;
}
else
flag = true;
}
if(flag) break;

}while(i < 3);

if(flag) Console.WriteLine(i); else Console.WriteLine("Line without negative numbers not exists");
}
}
Serjik Ok_Da!?
Serjik Ok_Da!?
3 269