Домашние задания: Информатика

Помогите пожалуйста нужно написать программу в паскале.

Известны длины сторон треугольника а,b, с и радиус круга r.Определить площадь закрашенной области
Исполнить программу для произвольного варианта исходных данных
V_
Venera _
569
var a, b, c, r, s: real;
begin
read(a, b, c, r);
s := 3.1416*r*r-sqrt((a+b+c)*(-a+b+c)*(a-b+c)*(a+b-c))/4;
write(s)
end.
ВС
Вячеслав Сергеев
75 861
Лучший ответ
Сложна
Вот тебе C++ кому не лень в паскаль переведут я не шарю

#define _USE_MATH_DEFINES
#include
#include
using namespace std;

int main()
{
double x1, y1, x2, y2, x3, y3;
// Считывае координаты середин сторон
cout << "First point: ";
cin >> x1 >> y1;
cout << "Second point: ";
cin >> x2 >> y2;
cout << "Third point: ";
cin >> x3 >> y3;
double a, b, c, p, r, s;
// Считаем длины сторон
a = sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1)) * 2;
b = sqrt((x3 - x2) * (x3 - x2) + (y3 - y2) * (y3 - y2)) * 2;
c = sqrt((x3 - x1) * (x3 - x1) + (y3 - y1) * (y3 - y1)) * 2;
// Считаем радиус окружности
p = (a + b + c) / 2;
r = a * b * c / 4 / sqrt(p * (p - a) * (p - b) * (p - c));
// Считаем площадь окружности
s = r * r * M_PI;
cout << "S = " << s;
}

Похожие вопросы