Помогите с информатикой.
Решать через Паскаль.
1)Дан целочисленный массив M из [10] элементов. Элементы массива могут принимать значения от 0 до 100 включительно. Составьте программу на языке Паскаль, позволяющий найти и вывести количество пар элементов массива, у которых произведение больше 100. Под парой подразумевается два подряд идущих элемента массива. 
2)Дан массив W с размерностью элементов [12], заполненный случайными числами {-30;50}. Найти максимальный элемент массива и поменять его с последним элементом. Вывести полученный массив на эран (не понял что за "эран", думаю что это экран). Состваьте программу. 
Ещё задание на картинках. 4 задание выделил серым. И на другой картинке два задание (3 и 4)
 
 
		
		
								
				begin
 writeln('1)');
 var m: array[1..10] of integer;
 var cnt: integer;
 for var i := 1 to 10 do begin m[i] := random(21); write(m[i]:4) end;
 for var i := 1 to 9 do if m[i]*m[i+1] > 100 then inc(cnt);
 writeln(#10, cnt);
 
 writeln('2)');
 var w: array[1..12] of integer;
 var max := 1;
 for var i := 1 to 12 do begin w[i] := random(81)-30; write(w[i]:4) end;
 for var i := 1 to 12 do if w[i] > w[max] then max := i;
 var tmp := w[12]; w[12] := w[max]; w[max] := tmp;
 writeln(#10, w);
 
 writeln('4-1)');
 var s: array[1..5,1..6] of integer;
 var ind: array of (integer, integer);
 var sum: integer;
 for var i := 1 to 5 do begin
 for var j := 1 to 6 do begin
 s[i,j] := random(21); write(s[i,j]:4);
 if not(odd(s[i,j])) then begin
 sum += s[i,j];
 SetLength(ind, length(ind)+1);
 ind[high(ind)] := (i,j);
 end;
 end;
 writeln;
 end;
 writeln(sum, #10, ind);
 
 writeln('3)');
 var f: array[1..4,1..4] of integer;
 var diag: integer;
 for var i := 1 to 4 do begin
 for var j := 1 to 4 do begin
 f[i,j] := random(91)+10; write(f[i,j]:4);
 end;
 writeln;
 end;
 for var i := 1 to 4 do
 for var j := 1 to 4 do
 if i=j then diag += f[i,j];
 writeln(diag);
 
 writeln('4-2)');
 var s2: array[1..5,1..5] of integer;
 var row: array[1..5] of integer;
 for var i := 1 to 5 do begin
 for var j := 1 to 5 do begin
 s2[i,j] := random(61)+20; write(s2[i,j]:4);
 row[i] += s2[i,j];
 end;
 writeln;
 end;
 write(row);
end.