1. Вывести с клавиатуры 5 чисел ,программа должна поменять чиста местами 1-4,2-1,3-3,4-5,5-2
2. Написать программу, которая считает длину окружности и площадь круга, радиус вводится с клавиатуры
	
	
	Домашние задания: Информатика
	
		
		
								
				
								
				
			
	
		
			Программы на языке паскаль.Задачи
Названия программ использую P1 и P2 - соответственно P1 - 1-ая программа (по заданию 1), а P2 - 2-ая (с площадью круга и пр.):
Program P1;
uses crt;
var i: integer;
iv1, iv2, iv3, iv4, iv5: real;
a: array [1..5] of real;
begin
clrscr;
for i:=1 to 5 do begin
write ('Введите ', i, '-е число: ');
readln (a[i]);
end;
writeln ('');
write ('Вы ввели числа: ');
for i:=1 to 5 do begin
write (a[i], ' ');
end;
iv1:=a[1];
iv2:=a[2];
iv3:=a[3];
iv4:=a[4];
iv5:=a[5];
for i:=1 to 5 do begin
a[1]:=iv4;
a[2]:=iv1;
a[3]:=iv3;
a[4]:=iv5;
a[5]:=iv2;
end;
writeln ('');
write ('Числа, после перемены мест: ');
for i:=1 to 5 do begin
write (a[i], ' ');
end;
readkey;
end.
Program P2;
uses crt;
var C, R, S: real;
o: integer;
label l, l1, l2;
begin
clrscr;
l:;
write ('Введите радиус окружности: ');
readln (R);
C:=2*pi*R;
S:=pi*sqr (R);
if R<0 then begin
l1:;
write ('Ошибка: радиус окружности не может быть отрицательным. Нажмите 1 чтобы повторить ввод радиуса или 2 для выхода из программы.');
readln (o);
begin
if o=1 then goto l;
if o=2 then goto l2 else begin
write ('Ошибка ввода. Пожалуйста, попробуйте снова.');
goto l1;
end;
end;
end;
writeln ('Длина окружности: C=', C);
write ('Площадь круга: S=', S);
l2:
readkey;
end.
				
							Program P1;
uses crt;
var i: integer;
iv1, iv2, iv3, iv4, iv5: real;
a: array [1..5] of real;
begin
clrscr;
for i:=1 to 5 do begin
write ('Введите ', i, '-е число: ');
readln (a[i]);
end;
writeln ('');
write ('Вы ввели числа: ');
for i:=1 to 5 do begin
write (a[i], ' ');
end;
iv1:=a[1];
iv2:=a[2];
iv3:=a[3];
iv4:=a[4];
iv5:=a[5];
for i:=1 to 5 do begin
a[1]:=iv4;
a[2]:=iv1;
a[3]:=iv3;
a[4]:=iv5;
a[5]:=iv2;
end;
writeln ('');
write ('Числа, после перемены мест: ');
for i:=1 to 5 do begin
write (a[i], ' ');
end;
readkey;
end.
Program P2;
uses crt;
var C, R, S: real;
o: integer;
label l, l1, l2;
begin
clrscr;
l:;
write ('Введите радиус окружности: ');
readln (R);
C:=2*pi*R;
S:=pi*sqr (R);
if R<0 then begin
l1:;
write ('Ошибка: радиус окружности не может быть отрицательным. Нажмите 1 чтобы повторить ввод радиуса или 2 для выхода из программы.');
readln (o);
begin
if o=1 then goto l;
if o=2 then goto l2 else begin
write ('Ошибка ввода. Пожалуйста, попробуйте снова.');
goto l1;
end;
end;
end;
writeln ('Длина окружности: C=', C);
write ('Площадь круга: S=', S);
l2:
readkey;
end.
program dz2;
uses crt;
var r:real;
const pi=3.14;
label 1;
begin
1: write('wwedite r ='); read(r);
if r<=0 then goto 1;
writeln('dlina okrugnosti L=2*pi*r =',2*pi*r:4:4);
writeln;
writeln('ploshad kruga. S=pi*r*r =',pi*sqr(r):4:4);
end.
				
							uses crt;
var r:real;
const pi=3.14;
label 1;
begin
1: write('wwedite r ='); read(r);
if r<=0 then goto 1;
writeln('dlina okrugnosti L=2*pi*r =',2*pi*r:4:4);
writeln;
writeln('ploshad kruga. S=pi*r*r =',pi*sqr(r):4:4);
end.
Похожие вопросы
- Короче, помогите написать программу на языке паскаля где нужно--->
- Написать программы с помощью паскаля. Срочно помогите!
- как сделать с циклом следущуюю задачу по информатике на языке паскаль.
- Напишите код программы для решения данной задачи.
- Информатика 8 класс. Начало программирования на языке Паскаль.
- Домашняя работа по Информатике. Записать на языке Паскаль.
- Домашняя работа по Информатике. Записать на языке Паскаль.
- Информатика язык:Паскаль. Помогите пожалуйста!!
- Помогите найти ошибки в программировании на языке паскаль
- Напишите, пожалуйста программу на языке раскаль Pascal ABC
