Написать фио отдельно, вывести приветствие по типу: Здравствуйте уважаемый (уважаемая) и фамилия, имя.
Это всё должна быть разветвляющаяся программа
Помогите позязя )
	
	
	Домашние задания: Информатика
	
		
		
								
				
								
				
																				
							
			
	
		
			Короче, помогите написать программу на языке паскаля где нужно--->
Я немного не понял: как именно нужно вывести? В виде таблицы? Или а-ля "Введите фамилию" -> "Введите имя" -> (? надо ли?)" Введите отчество" -> "Здравствуйте, уважаемый (-ая) {Фамилия} {Имя} {?Отчество}"? Если 2-ой вариант, то вот текст программы (Не знаю, как хорошо Вы владеете языком Pascal, поэтому напишу подробно чтобы поняли абсолютно все. Если сложно читать, то в комментарии к ответу я выложу только текст самой программы без комментариев. В фигурных скобках ({}) пишу комментарии, их писАть необязательно, но я напишу для понимания, соответственно открывающая скобка ({) - начало комментария, закрывающая (}) - конец комментария):
Program Privetstvie; {имя программы}
uses crt; {подключаем модуль crt - модуль отдельного текстового окна, монитора и клавиатуры}
var s, n, p: string[30]; {можно просто string без скобок - скобки (число, указанное в скобках) - длина строки в символах (буквах - количество букв, пробел - тоже своего рода буква, т. е. он тоже считается); здесь мы описываем переменные, которые будут использоваться и их тип - буквы - любые, можно целые слова, но для краткости я использовал первые буквы: s - surname - фамилия, n - name - имя, p - patronymic - отчество. Т. к. буквы - любые (главное, чтобы не повторялись, то Вы можете использовать, например, a, b, c}
o: string; {ответ-приветствие - т. к. может быть длинным - то просто string в моем случае. В предыдущих я экономил память компа, хоть и считанные биты, но все же экономные программисты пользуются уважением, это - признак хорошего тона}
begin {начинаем выполнение программы}
clrscr; {очищаем экран от лишней необязательной информации вроде версии компилятора Pascal, т. е. начинаем с чистого листа (в нашем случае - с чистого экрана) }
write ('Введите Вашу фамилию: '); {Выводим строку с соответствующей надписью (указана в (''), ждем ввода текста (на данном этапе - фамилии) и ждем нажатия клавиши Enter}
readln (s); {считываем фамилию. Обратите внимание: ln на конце - означает перенос на следующую строку и без ожидания нажатия клавиши Enter}
write ('Введите Ваше имя'); {Здесь и далее - аналогично для имени и отчества}
readln (n);
write ('Введите Ваше отчество'); {Если отчество не нужно вводить, то эти 2 строчки (write и readln для отчества) не пишите и удалите p из var (выше) и ниже справа от n, т. е. сразу после n закройте скобку}
readln (p);
write ('Здравствуйте, уважаемый (-ая)', ' ', s, ' ', n, ' ', p); {Выводим приветствие. А дабы оно не было слитно, т. е. а-ля "Здравствуйте, уважаемый (-ая) СидоровИванПетрович", то перед каждым выводом соответствующего текста, я поставил пробел, для того, чтобы вывести его на экран, пишу апострофы (вывод видимого текста) и между ними (в них, как в кавычках) пишу пробелы - это Вы можете увидеть перед всеми 3 буквами}
readkey; {На всякий случай (если используется Turbo Pascal) ждем нажатия клавиши, чтобы выйти из программы, давая прочитать текст, а не сразу вылет}
end. {Собственно, конец программы}
				
									Program Privetstvie; {имя программы}
uses crt; {подключаем модуль crt - модуль отдельного текстового окна, монитора и клавиатуры}
var s, n, p: string[30]; {можно просто string без скобок - скобки (число, указанное в скобках) - длина строки в символах (буквах - количество букв, пробел - тоже своего рода буква, т. е. он тоже считается); здесь мы описываем переменные, которые будут использоваться и их тип - буквы - любые, можно целые слова, но для краткости я использовал первые буквы: s - surname - фамилия, n - name - имя, p - patronymic - отчество. Т. к. буквы - любые (главное, чтобы не повторялись, то Вы можете использовать, например, a, b, c}
o: string; {ответ-приветствие - т. к. может быть длинным - то просто string в моем случае. В предыдущих я экономил память компа, хоть и считанные биты, но все же экономные программисты пользуются уважением, это - признак хорошего тона}
begin {начинаем выполнение программы}
clrscr; {очищаем экран от лишней необязательной информации вроде версии компилятора Pascal, т. е. начинаем с чистого листа (в нашем случае - с чистого экрана) }
write ('Введите Вашу фамилию: '); {Выводим строку с соответствующей надписью (указана в (''), ждем ввода текста (на данном этапе - фамилии) и ждем нажатия клавиши Enter}
readln (s); {считываем фамилию. Обратите внимание: ln на конце - означает перенос на следующую строку и без ожидания нажатия клавиши Enter}
write ('Введите Ваше имя'); {Здесь и далее - аналогично для имени и отчества}
readln (n);
write ('Введите Ваше отчество'); {Если отчество не нужно вводить, то эти 2 строчки (write и readln для отчества) не пишите и удалите p из var (выше) и ниже справа от n, т. е. сразу после n закройте скобку}
readln (p);
write ('Здравствуйте, уважаемый (-ая)', ' ', s, ' ', n, ' ', p); {Выводим приветствие. А дабы оно не было слитно, т. е. а-ля "Здравствуйте, уважаемый (-ая) СидоровИванПетрович", то перед каждым выводом соответствующего текста, я поставил пробел, для того, чтобы вывести его на экран, пишу апострофы (вывод видимого текста) и между ними (в них, как в кавычках) пишу пробелы - это Вы можете увидеть перед всеми 3 буквами}
readkey; {На всякий случай (если используется Turbo Pascal) ждем нажатия клавиши, чтобы выйти из программы, давая прочитать текст, а не сразу вылет}
end. {Собственно, конец программы}
„на языке паскаля“ Это про какого Паскаля? Блеза Паскаля? Дык, он французом был! На французском получается… А при чём здесь программа?
				
									
								
									Элегантное Нижнее Бельё								
								Подловил, ну программисты поймут про что я )							
											Похожие вопросы
- Написать программы с помощью паскаля. Срочно помогите!
- Срочно Помогите написать программу по задаче (на любом языке программирования)
- Программы на языке паскаль.Задачи
- Помогите написать программу в PascalABS с случайными числами
- Помогите пожалуйста нужно написать программу в паскале.
- (Паскаль) Написать программу для вычисления функции y= x+1 при x<6 ; 2*x-1 при x>=0
- Помогите, надо написать программу, чтобы она вывела текстом "Привет" 5 раз на паскале
- Помогите нужно написать программу буду благодарен
- Помогите с дз по информатике. Паскаль. 9 класс.
- Информатика язык:Паскаль. Помогите пожалуйста!!
 
			 
						
uses crt;
var s, n, p: string[30];
o: string;
begin
clrscr;
write ('Введите Вашу фамилию: ');
readln (s);
write ('Введите Ваше имя');
readln (n);
write ('Введите Ваше отчество');
readln (p);
write ('Здравствуйте, уважаемый (-ая)', ' ', s, ' ', n, ' ', p);
readkey;
end.