Есть 2 задания. Нужно написать программы на языке паскаль ( в программе PascalABC.NET желательно)
Задание 1
 Составить блок-схему алгоритма и программу на языке Паскаль для решения задачи.
Найдите количество положительных элементов одномерного массива, которые без остатка делятся на 4 и принадлежат промежутку от 10 до 30. Количество элементов массива и их значения задайте самостоятельно путём ввода с клавиатуры.
Задание 2
 Составить программу на языке Паскаль для решения задачи.
Дан одномерный массив из 15 элементов, заполненный случайным образом в диапазоне от –40 до 40. Замените на ноль значения всех элементов, расположенных на нечётных позициях в массиве. Выведите на экран весь полученный ряд значений.
( P.S я из ИнтернетУрок. Кто тоже, то напишите если хотите в чат с домашкой в тг)
	
	
	Домашние задания: Информатика
	
		
		
								
				
								
				
								
				
								
				
								
				
			
	
		
			Помогите с дз по информатике. Паскаль. 9 класс.
Программы обозначаю как P1 (Program P1) и P2 - соответственно P1 - к 1-ому заданию, P2 - ко 2-ому.
Кстати, в 1-ом: какой именно промежуток (границы строгие или включая эти числа)?
1)
Program P1;
uses crt;
const n=10;
type massiv=array [1..n] of integer;
var m: massiv;
i, k: integer;
begin
clrscr;
k:=0;
for i:=1 to n do begin
write ('Введите ', i, '-й элемент массива, после чего нажмите клавишу Enter: ');
readln (m[i]);
end;
for i:=1 to n do begin
if (m[i]>0) and (m[i] mod 4=0) and (m[i]>=10) and (m[i]<=30) then k:=k+1;
end;
writeln ('Количество положительных элементов одномерного массива, которые без остатка делятся на 4 и принадлежат промежутку от 10 до 30 составляет: ', k);
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
2)
Program P2;
uses crt;
const n=15;
type massiv=array [1..n] of integer;
var m: massiv;
i: integer;
begin
clrscr;
for i:=1 to n do begin
m[i]:=random (81)-40;
end;
write ('Был сгенерирован массив:');
for i:=1 to n do begin
write (' ', m[i]);
end;
writeln ('');
for i:=1 to n do begin
if i mod 2<>0 then m[i]:=0;
end;
write ('Этот массив после изменения: ');
for i:=1 to n do begin
write (' ', m[i]);
end;
writeln (' ');
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
				
							Кстати, в 1-ом: какой именно промежуток (границы строгие или включая эти числа)?
1)
Program P1;
uses crt;
const n=10;
type massiv=array [1..n] of integer;
var m: massiv;
i, k: integer;
begin
clrscr;
k:=0;
for i:=1 to n do begin
write ('Введите ', i, '-й элемент массива, после чего нажмите клавишу Enter: ');
readln (m[i]);
end;
for i:=1 to n do begin
if (m[i]>0) and (m[i] mod 4=0) and (m[i]>=10) and (m[i]<=30) then k:=k+1;
end;
writeln ('Количество положительных элементов одномерного массива, которые без остатка делятся на 4 и принадлежат промежутку от 10 до 30 составляет: ', k);
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
2)
Program P2;
uses crt;
const n=15;
type massiv=array [1..n] of integer;
var m: massiv;
i: integer;
begin
clrscr;
for i:=1 to n do begin
m[i]:=random (81)-40;
end;
write ('Был сгенерирован массив:');
for i:=1 to n do begin
write (' ', m[i]);
end;
writeln ('');
for i:=1 to n do begin
if i mod 2<>0 then m[i]:=0;
end;
write ('Этот массив после изменения: ');
for i:=1 to n do begin
write (' ', m[i]);
end;
writeln (' ');
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
Задание 2 

				
							
Если вам нужны ответы в домашней школе ИнтернетУрок - в телеграмме есть группа с ответами:  https://t.me/dostup10class 
Там есть ответы в интернет уроке на домашние задания/аттестации и другого для всех классов)
				
							Там есть ответы в интернет уроке на домашние задания/аттестации и другого для всех классов)
я хочу в тг
				
									Программы обозначаю как P1 (Program P1) и P2 - соответственно P1 - к 1-ому заданию, P2 - ко 2-ому. 
 
Кстати, в 1-ом: какой именно промежуток (границы строгие или включая эти числа)?
 
1)
Program P1;
uses crt;
const n=10;
type massiv=array [1..n] of integer;
var m: massiv;
i, k: integer;
begin
clrscr;
k:=0;
for i:=1 to n do begin
write ('Введите ', i, '-й элемент массива, после чего нажмите клавишу Enter: ');
readln (m[i]);
end;
for i:=1 to n do begin
if (m[i]>0) and (m[i] mod 4=0) and (m[i]>=10) and (m[i]<=30) then k:=k+1;
end;
writeln ('Количество положительных элементов одномерного массива, которые без остатка делятся на 4 и принадлежат промежутку от 10 до 30 составляет: ', k);
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
 
2)
Program P2;
uses crt;
const n=15;
type massiv=array [1..n] of integer;
var m: massiv;
i: integer;
begin
clrscr;
for i:=1 to n do begin
m[i]:=random (81)-40;
end;
write ('Был сгенерирован массив:');
for i:=1 to n do begin
write (' ', m[i]);
end;
writeln ('');
for i:=1 to n do begin
if i mod 2<>0 then m[i]:=0;
end;
write ('Этот массив после изменения: ');
for i:=1 to n do begin
write (' ', m[i]);
end;
writeln (' ');
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
				
							Кстати, в 1-ом: какой именно промежуток (границы строгие или включая эти числа)?
1)
Program P1;
uses crt;
const n=10;
type massiv=array [1..n] of integer;
var m: massiv;
i, k: integer;
begin
clrscr;
k:=0;
for i:=1 to n do begin
write ('Введите ', i, '-й элемент массива, после чего нажмите клавишу Enter: ');
readln (m[i]);
end;
for i:=1 to n do begin
if (m[i]>0) and (m[i] mod 4=0) and (m[i]>=10) and (m[i]<=30) then k:=k+1;
end;
writeln ('Количество положительных элементов одномерного массива, которые без остатка делятся на 4 и принадлежат промежутку от 10 до 30 составляет: ', k);
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
2)
Program P2;
uses crt;
const n=15;
type massiv=array [1..n] of integer;
var m: massiv;
i: integer;
begin
clrscr;
for i:=1 to n do begin
m[i]:=random (81)-40;
end;
write ('Был сгенерирован массив:');
for i:=1 to n do begin
write (' ', m[i]);
end;
writeln ('');
for i:=1 to n do begin
if i mod 2<>0 then m[i]:=0;
end;
write ('Этот массив после изменения: ');
for i:=1 to n do begin
write (' ', m[i]);
end;
writeln (' ');
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
Похожие вопросы
- Информатика. Паскаль 8 класс
- Помогите с дз по информатике
- Помогите решить дз по информатике
- Срочноо помогите с дз по информатике
- Помогите с задачами по информатике, пожалуйста! 8 класс
- Информатика 9 класс
- Помогите пожалуйста с дз по информатике 8класс (паскаль) если можно с объяснением, а то тема не понятна
- Информатика 9 класс. Паскаль. Даю 10 баллов
- Задание по информатике. 9 Класс
- Помогите срочно!!!!Информатика ПАСКАЛЬ
 
			 
						 
						 
						
это бот с гдз, тоже может помочь
Там есть ответы в интернет уроке на домашние задания/аттестации и другого для всех классов)