Домашние задания: Информатика
Информатика 9 класс. Паскаль. Даю 10 баллов
Составьте программу, для вычесления значения выражения 34-2/4+2*(-3) если что дробь - /
То, что "/" - дробь - понятно. Тут вопрос вот в чем: дробь "короткая", т.е. 2/4 или же "длинная", т.е. в знаменателе 4+2*(-3)? Ладно, напишу по 1-ому варианту (с "короткой" дробью). Если что - достаточно изменить в программе лишь 1 строку. Конкретнее, что нужно изменить, в случае, если я неправильно понял задание, напишу после программы. А пока что вот программа:
Program P1;
uses crt;
begin
clrscr;
writeln ('34-2/4+2*(-3) = ', 34-2/4+2*(-3));
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end. Значит, прежде чем напишу, что изменять, напомню (а заодно поясню, почему выражение я написАл 2 раза, если кому непонятно): то, что написано в апострофах (одинарных кавычках) выведется на экран как текст, а то, что вне апострофов (но в скобках после write или (как в данном случае) writeln) уже как значение. Теперь же, как, думаю, уже видно, что нужно изменить в случае чего, - собственно в эту строку к знаменателю остается приписАть скобки, т.е. "4+2*(-3)" возвести в круглые скобки, получив выражение: 34-2/(4+2*(-3)). Т.е. строка "writeln ('34-2/4+2*(-3) = ', 34-2/4+2*(-3));" будет иметь вид: "writeln ('34-2/4+2*(-3) = ', 34-2/(4+2*(-3)));", а сама программа приобретет вид: Program P1;
uses crt;
begin
clrscr;
writeln ('34-2/(4+2*(-3)) = ', 34-2/(4+2*(-3)));
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
Юрий Зеель
Спасибо большое. Теперь вопрос, как баллы кинуть?
Юрий Зеель
Спасибо чувак) видно постарался
Так и будет:
y := 34 - 2/4 + 2*(-3)
y := 34 - 2/4 + 2*(-3)
Юрий Зеель
Не очень понял, я до этого делал прогу. А тут что-то другое
Похожие вопросы
- Информатика 9 класс
- Задание по информатике. 9 Класс
- Информатика 8 класс, паскаль
- ПОМОГИТЕ С ИНФОРМАТИКОЙ 9 КЛАСС!
- Помогите пожалуйста!!! Очень срочно, информатика, 9 класс!!!
- Информатика 9 класс
- Информатика 9 класс. Нужно решение с объяснением
- Информатика 9 класс pascal(mod,div)
- Информатика, 9 класс
- Информатика 9 класс помогите пожалуйста!