Домашние задания: Информатика
	
		
		
								
				
								
				
								
				
			
	
		
			(Паскаль) Написать программу для вычисления функции y= x+1 при x<6 ; 2*x-1 при x>=0
Я вообще нихрена не понимаю, я учусь в 9 классе, учитель объяснил нам на последнем уроке что такое массив, сказал как им пользовать и показал, потом посадил за компы и сказал написать программу для вычисления этой функции, в итоге "классная" работа стала домашней и я всю неделю ломаю голову и нихрена не понимаю нужен ли здесь этот массив или нет, в интернете тоже нихера не нашёл ( но возможно плохо искал) прошу помогите + я сам хочу узнать как решить это
	
	
	Тут зависит от задания. И тут Вам бы лучше спросить у своего учителя. Потому как по факту массив-то тут не нужен. Массив - это несколько значений, несколько чисел. Так же неплохо было бы у учителя спросить, а как задаётся x - 1 значение пользователь вводит с клавиатуры, x заранее известен (как константа), x генерируется генератором случайных чисел, или x может принимать несколько значений (находится в каком-либо промежутке или интервале). А учитель мог дать задание не по текущей теме с массивами, а по предыдущей.
Вот, например, такая программа. Значение x вводится с клавиатуры (после чего нужно нажать Enter):
Program P1;
uses crt;
var x, y: real;
begin
clrscr;
write ('Введите значение переменной x: x=');
readln (x);
if x<6 then y:=x+1 else y:=2*x-1;
write ('Ответ: y=', y);
readkey;
end.
				
							Вот, например, такая программа. Значение x вводится с клавиатуры (после чего нужно нажать Enter):
Program P1;
uses crt;
var x, y: real;
begin
clrscr;
write ('Введите значение переменной x: x=');
readln (x);
if x<6 then y:=x+1 else y:=2*x-1;
write ('Ответ: y=', y);
readkey;
end.
Что ж вы так, галопом, дык конечно усе смешается.. Не нужен тута массиф! Просто пишите, что 
function f (var x : real)
begin
if x < 0 then f = x+1;
else f = 2*x - 1;
end
Усё!
				
							function f (var x : real)
begin
if x < 0 then f = x+1;
else f = 2*x - 1;
end
Усё!
Посмотри в инете, как составить программу в паскаль, но знаю, что в начале ставишь begin в конце end. И вроде скорее всего тебе надо ввести переменную для того что бы ввести число, не знаю как в Паскаль, но в pythone можно сделать так: name = Andrey и если захочешь чтобы это имя ввелось то потом пишешь ,"Hello world " + name только там надо специальные знаки чекай в инете надеюсь помог, удачи
				
							Похожие вопросы
- Короче, помогите написать программу на языке паскаля где нужно--->
- Написать программы с помощью паскаля. Срочно помогите!
- Помогите пожалуйста нужно написать программу в паскале.
- 1) Напишите программу для подсчета произведения чисел введённых пользователем.
- Написать программу вычисления суммы кодов своего имени: АГАШ
- Помогите, надо написать программу, чтобы она вывела текстом "Привет" 5 раз на паскале
- Напишите программы в PascalABC.
- Срочно Помогите написать программу по задаче (на любом языке программирования)
- Программа для вычисления площади прямоугольника
- Напишите программу которая с помощью цикла For-NEXT выводит на экран рисунок «Крылья»
