За основу возьмите программу суммы чисел из конспекта, и измените её так, чтобы она подсчитывала не сумму, а произведение введённых чисел. Выход по прежнему при вводе 0.
2) Напишите программу, которая выводит на экран весь ряд последовательности Фибоначчи, с 1 до n (n – число вводится пользователем с клавиатуры). За основу возьмите программу из конспекта, которая выводит только последние 2 члена последовательности, и переделайте её так, чтобы она выводила на экран все числа Фибоначчи от 1 до n.
	
	
	Домашние задания: Информатика
	
		
		
								
				
								
				
			
	
		
			1) Напишите программу для подсчета произведения чисел введённых пользователем.
Уважаемая Александра, вопрос Вы задали несколько некорректно. Дело в том, что Ваше задание требует переделать уже, как минимум, 1 готовую программу из конспекта, который Вы не предоставили. Ведь некоторые программы могут быть написаны по-разному, из-за чего написанная кем-либо из нас программа может не совпасть с конспектом. Так же Вы не указали требуемый язык программирования - ведь тексты программ будут разные. Но ладно, напишу, как я вижу (на языке Паскаль):
1) Program P1;
uses crt;
const n=10;
var i, p: integer;
a: array [1..n] of integer;
begin
clrscr;
for i:=1 to n do begin
write ('Введите очередной элемент массива: ');
readln (a[i]);
end;
p:=1;
for i:=1 to n do begin
p:=p*a[i];
end;
write ('Произведение элементов массива: ', p);
readkey;
end.
2) Program P2;
uses crt;
var
a, b, c, i, n: integer;
begin
clrscr;
write('Введите количество элементов ряда Фибоначчи: ');
readln(n);
a := 0;
write(a,' ');
b := 1;
write(b,' ');
for i:=3 to n do begin
write(a+b,' ');
c := b;
b := a + b;
a := c;
end;
readkey;
end.
				
							1) Program P1;
uses crt;
const n=10;
var i, p: integer;
a: array [1..n] of integer;
begin
clrscr;
for i:=1 to n do begin
write ('Введите очередной элемент массива: ');
readln (a[i]);
end;
p:=1;
for i:=1 to n do begin
p:=p*a[i];
end;
write ('Произведение элементов массива: ', p);
readkey;
end.
2) Program P2;
uses crt;
var
a, b, c, i, n: integer;
begin
clrscr;
write('Введите количество элементов ряда Фибоначчи: ');
readln(n);
a := 0;
write(a,' ');
b := 1;
write(b,' ');
for i:=3 to n do begin
write(a+b,' ');
c := b;
b := a + b;
a := c;
end;
readkey;
end.
1)
#define ll long long
#define ld long double
using namespace std;
signed main() {
ll n;
cin >> n;
ll ans = 1;
while(n--){
ll x;
cin >> x;
ans *= x;
}
cout << ans;
}
2)
#define ll long long
#define ld long double
using namespace std;
ll fibo(ll n){
if(n == 1 || n == 2)
return 1;
return fibo(n-1) + fibo(n-2);
}
signed main() {
ll n;
cin >> n;
ll x = 1;
while(fibo(x) < n){
cout << fibo(x) << " ";
x++;
}
}
				
							#define ll long long
#define ld long double
using namespace std;
signed main() {
ll n;
cin >> n;
ll ans = 1;
while(n--){
ll x;
cin >> x;
ans *= x;
}
cout << ans;
}
2)
#define ll long long
#define ld long double
using namespace std;
ll fibo(ll n){
if(n == 1 || n == 2)
return 1;
return fibo(n-1) + fibo(n-2);
}
signed main() {
ll n;
cin >> n;
ll x = 1;
while(fibo(x) < n){
cout << fibo(x) << " ";
x++;
}
}
Похожие вопросы
- Создайте программу, которая проверяет, является ли хотя бы одно из трех чисел, введенных с клавиатуры, четным.
- Помогите написать программу в PascalABS с случайными числами
- (Паскаль) Написать программу для вычисления функции y= x+1 при x<6 ; 2*x-1 при x>=0
- Напишите программу, которая в последовательности целых чисел определяет их количество и сумма четных чисел
- Напишите программы в PascalABC.
- Напишите программу, которая вычисляет квадрат наименьшего из четырёх чисел
- Срочно Помогите написать программу по задаче (на любом языке программирования)
- Помогите пожалуйста нужно написать программу в паскале.
- Напишите программу которая с помощью цикла For-NEXT выводит на экран рисунок «Крылья»
- Короче, помогите написать программу на языке паскаля где нужно--->
 
			 
						