Домашние задания: Информатика
Создайте программу, которая проверяет, является ли хотя бы одно из трех чисел, введенных с клавиатуры, четным.
Например, для чисел 10, 15, 20 – «нет», а для чисел 10, 20, 30 – «да».
PascalABC:


Программу, значит, написать... - Это можно. Только вот на каком языке программирования это нужно сделать? - Нет, программе-то, конечно, без разницы, на каком языке программирования (а их (языков программирования) существует порядка 40) она написана, а вот учитель/преподаватель может спросить, с чего это программа была написана на этом языке программирования, а не на том, который он(а) преподает.
Вот, например, на Pascal:
Вот, например, на Pascal:
Program P1;
uses crt;
var a, b, c: integer;
begin
clrscr;
writeln ('Введите с клавиатуры 3 целых числа (по 1). После ввода каждого числа нажимайте клавишу Enter.');
write ('Введите 1-ое число: ');
readln (a);
write ('Введите 2-ое число: ');
readln (b);
write ('Введите 3-е число: ');
readln (c);
if (a mod 2=0) or (b mod 2=0) or (c mod 2=0) then writeln ('Да, хотя бы 1 число из введенных четное.') else writeln ('Среди введенных чисел нет четных.');
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end. Вот на Python: print ("Введите с клавиатуры 3 целых числа (по 1). После ввода каждого числа нажимайте клавишу Enter.")
a=int (input (f"Введите 1-ое число: "))
b=int (input (f"Введите 2-ое число: "))
c=int (input (f"Введите 3-е число: "))
if a%2==0 or b%2==0 or c%2==0:
print ("Да, хотя бы 1 число из введенных четное.")
else:
print ("Среди введенных чисел нет четных.") Вот на C++: #include
using namespace std;
int main()
{
setlocale (LC_ALL, "RUS");
int a, b, c;
coutnum1 = int(input("Введите первое число: "))
num2 = int(input("Введите второе число: "))
num3 = int(input("Введите третье число: "))
if num1 % 2 == 0 or num2 % 2 == 0 or num3 % 2 == 0:
print("Да, есть хотя бы одно четное число")
else:
print("Нет, нет ни одного четного числа")
num2 = int(input("Введите второе число: "))
num3 = int(input("Введите третье число: "))
if num1 % 2 == 0 or num2 % 2 == 0 or num3 % 2 == 0:
print("Да, есть хотя бы одно четное число")
else:
print("Нет, нет ни одного четного числа")
Похожие вопросы
- Помогите советами, создать программу, которая будет определять психическое состояние человека
- 1) Напишите программу для подсчета произведения чисел введённых пользователем.
- Напишите программу, которая в последовательности целых чисел определяет их количество и сумма четных чисел
- Напишите программу, которая вычисляет квадрат наименьшего из четырёх чисел
- Напишите программу которая с помощью цикла For-NEXT выводит на экран рисунок «Крылья»
- Помогите на Pascal сделать программу, которая считает количество дней до лета.
- Написать диалоговую программу, которая спрашивает у вас: «Какая сегодня дата?»
- Написать диалоговую программу, которая спрашивает у вас: «Какой твой любимый предмет, какую оценку ты по нему имеешь?».
- Написать диалоговую программу, которая спрашивает у вас: «Какой твой любимый предмет, какую оценку ты по нему имеешь?»
- Напишите программу которая вычисляет SS=(a+b+a)/(a*b*b)