Домашние задания: Информатика
	
		
		
								
				
			
	
		
			Программа для вычисления площади прямоугольника
Программу, значит, написать... - Это можно. Только вот на каком языке программирования это нужно сделать? - Нет, программе-то, конечно, без разницы, на каком языке программирования она написана, а вот учитель/преподаватель может спросить, с чего это вдруг программа написана именно на этом языке программирования, а не на том, который он(а) преподает.
Да и формула странная - для площади прямоугольника используется другая формула: S=a*b, где a и b - его стороны (длина и ширина). Так что нужно сделать-то? - Для прямоугольника или по той формуле написать? Ладно, напишу и так, и так.
Вот программы на Паскале (Pascal):
1) Площадь прямоугольника (S=a*b):
				
							Да и формула странная - для площади прямоугольника используется другая формула: S=a*b, где a и b - его стороны (длина и ширина). Так что нужно сделать-то? - Для прямоугольника или по той формуле написать? Ладно, напишу и так, и так.
Вот программы на Паскале (Pascal):
1) Площадь прямоугольника (S=a*b):
 Program P1; 
uses crt; 
var a, b: real; 
begin 
clrscr; 
writeln ('Эта программа вычисляет площадь прямоугольника. Введите его стороны (с клавиатуры). При вводе дробных значений целую часть от дробной отделяйте точкой, а не запятой. Вводите только числа. После ввода каждого числа нажимайте клавишу Enter.'); 
write ('Введите 1-ую сторону прямоугольника: a='); 
readln (a); 
write ('Введите 2-ую сторону прямоугольника: b='); 
readln (b); 
writeln ('Ответ: Площадь прямоугольника S=', a*b); 
write ('Программа завершена. Для выхода нажмите клавишу Enter.'); 
readkey; 
end. 2-ой вариант (по формуле с картинки, только там явно не прямоугольник): Program P1; 
uses crt; 
var a, n, rb, rm: real; 
begin 
clrscr; 
writeln ('Введите с клавиатуры значения для каждого параметра (только числа). При вводе дробных чисел, целую часть от дробной отделяйте точкой, а не запятой. После ввода каждого числа нажимайте клавишу Enter.'); 
write ('n='); 
readln (n); 
write ('a='); 
readln (a); 
write ('R='); 
readln (rb); 
write ('r='); 
readln (rm); 
writeln ('Ответ: S=', ((n*a)/2)*sqrt(sqr (rb)-(sqr (rm)/4))); 
write ('Программа завершена. Для выхода нажмите клавишу Enter.');   
readkey; 
end. Похожие вопросы
- (Паскаль) Написать программу для вычисления функции y= x+1 при x<6 ; 2*x-1 при x>=0
- Помогите решить стороны прямоугольника равны 35 см и 50 см вычислить его периметр и площадь
- Написать программу вычисления суммы кодов своего имени: АГАШ
- Алгоритм вычисления значений функций, информатика, помогите пожалуйста
- Напишите программы в PascalABC.
- 1) Напишите программу для подсчета произведения чисел введённых пользователем.
- Срочно Помогите написать программу по задаче (на любом языке программирования)
- Написать программы с помощью паскаля. Срочно помогите!
- Помогите пожалуйста нужно написать программу в паскале.
- Программы на языке паскаль.Задачи
 
			