Домашние задания: Информатика

Помогите пожалуйста написать программу на Си (максимально просто по возможности)

Amirbek Kartanov
Amirbek Kartanov
27
С псевдо-случайными вещественными числами из [-99;99], двумерной динамической матрицей и с выводом результатов на экран. Выводить матрицы в задании не требуется, но если всё же выводить, то размеры массива должны быть такие, чтобы он мог вмещаться в экран. Максимальный элемент ищется одновременно с формированием матрицы, что в задании не запрещено, а чтобы проверить элемент матрицы на чётность он приводится к целому типу.
#include <time.h>
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
using namespace std;
void print(double **x, int n, int m)
{
int i, j;
for (i = 0; i < n; i++)
{
for (j = 0; j < m; j++) printf("%4.0f", x[i][j]);
printf("\n");
}
}
int main()
{
int i, j, H, F;
double max = -1., **ZG;
printf("H F » ");
scanf("%d%d", &H, &F);
ZG = (double **) malloc(H * sizeof(double*));
for (i = 0; i < H; i++)
ZG[i] = (double *) malloc(F * sizeof(double));
srand(time(NULL));
for (i = 0; i < H; i++) for (j = 0; j < F; j++)
{
ZG[i][j] = rand() % 199 - 99.;
if (ZG[i][j] > max) max = ZG[i][j];
}
print(ZG, H, F);
printf("Max = %f\n", max);
for (i = 0; i < H; i++) for (j = 0; j < F; j++)
if ((int)ZG[i][j] % 2) ZG[i][j] = max;
print(ZG, H, F);
}
Лана Svetlana
Лана Svetlana
29 440
Лучший ответ
Amirbek Kartanov А возможно сделать динамическое выделение памяти?
Рустам Муртазин Можете пожалуйста ещё попробовать написать код для этой задачи? https://otvet.mail.ru/question/229108897