
Другие языки программирования и технологии
Информатики, выручайте, любые 5 заданий, пожалуйста!!! Нужно написать программу на языке паскаль.

решение на Turbo Pascal (Pascal ABC)
{program a7;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100)* ((n mod 100) div 10)* (n mod 10) ) mod 4 = 0 then writeln ('произведение цифр кратно "4" ')
else writeln (' произведение цифр некратно "4" ');
end.}
{program a24;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100) * (n mod 10) * ((n mod 100) div 10)) > 99 then write ('произведение цифр трехзначное')
else write (' произведение цифр двузначное');
end.}
{program a17;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100) + (n mod 10) + (n mod 100) div 10) >15 then write ('сумма цифр больше 15 ')
else write (' сумма цифр меньше или равна 15');
end.}
{program a21;
var n: integer;
b: boolean;
begin
write ('N=');
readln (n);
b:=false;
while n<>0 do
begin
if not odd(n mod 10) then b:=true;
n:=n div 10;
end;
if b then writeln ('среди цифр числа присутствуют четные ЦИФРЫ!')
else writeln ('отсутствуют четные ЦИФРЫ!')
end.}
{program a12;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100) + (n mod 10)) > ((n mod 100) div 10 +(n mod 10)) then write (' сумма 1-ой и 3-ей больше')
else
if ((n div 100) + (n mod 10)) < ((n mod 100) div 10 +(n mod 10)) then write (' сумма 2-ой и 3-ей больше')
else write (' 1-ая и 2-ая цифры равны');
end.}
{program a10;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100) - (n mod 10) = 0) and ((n mod 100) div 10 -(n mod 10) = 0) then write (' числа одинаковые')
else write (' числа разные');
end.}
{program a7;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100)* ((n mod 100) div 10)* (n mod 10) ) mod 4 = 0 then writeln ('произведение цифр кратно "4" ')
else writeln (' произведение цифр некратно "4" ');
end.}
{program a24;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100) * (n mod 10) * ((n mod 100) div 10)) > 99 then write ('произведение цифр трехзначное')
else write (' произведение цифр двузначное');
end.}
{program a17;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100) + (n mod 10) + (n mod 100) div 10) >15 then write ('сумма цифр больше 15 ')
else write (' сумма цифр меньше или равна 15');
end.}
{program a21;
var n: integer;
b: boolean;
begin
write ('N=');
readln (n);
b:=false;
while n<>0 do
begin
if not odd(n mod 10) then b:=true;
n:=n div 10;
end;
if b then writeln ('среди цифр числа присутствуют четные ЦИФРЫ!')
else writeln ('отсутствуют четные ЦИФРЫ!')
end.}
{program a12;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100) + (n mod 10)) > ((n mod 100) div 10 +(n mod 10)) then write (' сумма 1-ой и 3-ей больше')
else
if ((n div 100) + (n mod 10)) < ((n mod 100) div 10 +(n mod 10)) then write (' сумма 2-ой и 3-ей больше')
else write (' 1-ая и 2-ая цифры равны');
end.}
{program a10;
var n: integer;
begin
write ('N=');
readln (n);
if ((n div 100) - (n mod 10) = 0) and ((n mod 100) div 10 -(n mod 10) = 0) then write (' числа одинаковые')
else write (' числа разные');
end.}
Похожие вопросы
- Помогите пожалуйста! помогите написать программу на языке паскаль
- помогите пожалуйста, нужно составить программу на языке Паскаль
- Напишите программу на языке Паскаль для решения задачи:
- помогите, пожалуйста, написать программу на языке Паскаль
- написать программу на языке паскаль, буду благодарен
- люди!!! помогитеееее!!!напишите программу на языке паскаль для задач:
- Написать программу на языке паскаль возведение числа в степень. Степень вводится с клавиатуры.
- Нужно написать программу на языке С
- Помогите пожалуйста! нужно написать программу на C++
- Помогите пожалуйста, нужно написать программу в С++ (Visual Studio). Как можно проще.