1.Дан массив А (9) посчитать количество нулевых элементов в массиве.
2. Дан одномерный массив с именем А и размерностью 25. Найти наибольший и наименьший элементы массива и их разность.
Другие языки программирования и технологии
Помогите решить задание по информатике. Нужно написать программу по заданию (см. внутри)
Вот программа для C++, но могут быть ошибки.
11 Поиск минимального элемента массива
linclude <stdio.h> linclude <conio.h>
itdefine HB 5 // размер массива
aid main()
int a[HB]; // массив
int min; // номер минимального элемента
int i; // индекс массива
printf("ХпПоиск минимального элемента массива\п");
printf("Введите в одной строке элементы массива, \п");
printf("%i целых чисел, и нажмите <enter>\n", HB) ;
printf("-> ") ;
for (i = 0; i < HB; i++)
scanf("%i",&a);
min =0; // предположим, что первый эл-т минимальный // сравним оставшиеся эл-ты массива с минимальным
for (i = 1; i < HB; i++)
if (a < a[min]) min = i;
printf("Минимальный элемент массива: ");
printf("a[%i]=%i ", min+1, a[min]);
printf("\пДля завершения нажмите <enter>");
getch();
Взято и зкниги которую можно скачать.. .
C++ в задачах и примерах.
11 Поиск минимального элемента массива
linclude <stdio.h> linclude <conio.h>
itdefine HB 5 // размер массива
aid main()
int a[HB]; // массив
int min; // номер минимального элемента
int i; // индекс массива
printf("ХпПоиск минимального элемента массива\п");
printf("Введите в одной строке элементы массива, \п");
printf("%i целых чисел, и нажмите <enter>\n", HB) ;
printf("-> ") ;
for (i = 0; i < HB; i++)
scanf("%i",&a);
min =0; // предположим, что первый эл-т минимальный // сравним оставшиеся эл-ты массива с минимальным
for (i = 1; i < HB; i++)
if (a < a[min]) min = i;
printf("Минимальный элемент массива: ");
printf("a[%i]=%i ", min+1, a[min]);
printf("\пДля завершения нажмите <enter>");
getch();
Взято и зкниги которую можно скачать.. .
C++ в задачах и примерах.
1.
uses CRT;
const n = 9;
var a: array [1..n] of Integer; k,sum: Integer;
begin
clrscr;
for k:=1 to n do readln(a[k]);
sum:=0;
for k:=1 to n do if a[k] = 0 then sum:=sum+1;
writeln(sum);
readkey;
end.
2.
uses CRT;
const n = 25;
var a: array [1..n] of Integer; k,min,max: Integer;
begin
clrscr;
for k:=1 to n do readln(a[k]);
min:=a[1];
max::=a[1];
for k:=2 to n do
begin
if a[k] > max then max:=a[k];
if a[k] < min then min:=a[k];
end;
writeln('min=',min);
writeln('max=',max);
writeln('разность: ',max-min);
readkey;
end.
uses CRT;
const n = 9;
var a: array [1..n] of Integer; k,sum: Integer;
begin
clrscr;
for k:=1 to n do readln(a[k]);
sum:=0;
for k:=1 to n do if a[k] = 0 then sum:=sum+1;
writeln(sum);
readkey;
end.
2.
uses CRT;
const n = 25;
var a: array [1..n] of Integer; k,min,max: Integer;
begin
clrscr;
for k:=1 to n do readln(a[k]);
min:=a[1];
max::=a[1];
for k:=2 to n do
begin
if a[k] > max then max:=a[k];
if a[k] < min then min:=a[k];
end;
writeln('min=',min);
writeln('max=',max);
writeln('разность: ',max-min);
readkey;
end.
Похожие вопросы
- ПОМОГИТЕ ПОЖАЛУЙСТА, КТО ЗНАЕТ ИНФОРМАТИКУ. НУЖНО НАПИСАТЬ ПРОГРАММУ НА С++.
- Помогите решить задание по HTML/CSS в Dreamweaver
- Помогите написать программу по паскалю для задания! ( см. внутри)
- Информатики, выручайте, любые 5 заданий, пожалуйста!!! Нужно написать программу на языке паскаль.
- Что такое спам бот? Задание по информатике. Нужно написать реферат, для чего, какие бывают разновидности и так далее.
- помогите решить задание на pascal ABC
- Нужно написать программы в Паскале! Массивы! Срочно! Помогите!
- Помогите решить задание Pascal
- помогите решить задание на С++
- Помогите решить задание С++? Найти разницу в днях между двумя заданными датами???