Нужна помощь в написании программы. Какой язык лучше подойдет, как реализовать?

Дело в том, что я хочу написать программу, которая должна будет отправлять сообщение (цифру) на обычный php форум каждые n секунд. Какой язык лучше подойдет? Ссылки на исходники (если таковые есть) . Так же должна присутствовать форма для ввода логина и пороля от форума ( подключение идет через sql или php файл? ). Примерно изложить принцип на алгоритмическом я могу.

нач
цел n, x,k
n:=0
x:=например 10
нц для k от 1 до 50

задержка x секунд ( зы как написать на алг не знаю )
n:=n+1
отправление сообщение с значением переменной n

кц
кон

Может ли кто помочь?

Пишите на том языке, который знаете.
Если не знаете никакого, можете начать освоение с любого из php, perl, c#, java.
P.S выглядит вопрос именно так, как написано в комментарии.

Про кроссдоменность я писал в ответ на предыдущий пост. Почитайте про CURL в php, расписывать не буду,

Напишите на яваскрипте. Там есть таймеры, аякс, в общем, всё, что нужно для выполнения задачи. Если понадобится, можно будет потом обернуть это в НТА-приложение.

хм, даже не знаю что вам посоветовать)