Как скачать скайп на айфон 4 (4.2.1)??? пишет требуется новая версия ПО для загрузки...! качала с App Store!!

2.1) пишет требуется новая версия ПО для загрузки...! качала с App Store!

Вам правда нужна новая версия ( 5.0.1 ). Тогда после этого попробуйте

Идиотская ситуация. Никогда не отвечал вопросом на вопрос, но придётся. Зачем Вам скайп на Айфон?