Домашние задания: Информатика
	
		
		
								
				
								
				
			
	
		
			Информатика задача на массивы
Дан массив размерностью 7х7 из целых чисел. Напишите программу замены всех элементов массива кратных 5, стоящих на главной диагонали их удвоенным значением.
	
	
	А как заполняется массив? Пользователем с клавиатуры или автоматически при помощи генератора случайных чисел? - На всякий случай пишу оба варианта.
1) Ввод вручную с клавиатуры. После того, как набирается число, нужно нажать клавишу "Enter" (предупреждаю заранее: это долго вводить 49 чисел):
Program Zamena5;
uses crt;
type m=array [1..7, 1..7] of integer;
var a: m;
i, j: integer;
begin
clrscr;
for i:=1 to 7 do
for j:=1 to 7 do begin
write ('Введите ', a[i,j], ' элемент массива: ');
readln (a[i,j]);
end;
writeln ('Вы ввели следующий массив: ');
for i:=1 to 7 do
for j:=1 to 7 do begin
writeln (a[i,j]);
end;
for i:=1 to 7 do
for j:=1 to 7 do begin
if (i=j) and (a[i,j] mod 5 =0) then a[i,j]:=2*a[i,j];
end;
writeln ('Массив после замены чисел, кратных 5 на главной диагонали: ');
for i:=1 to 7 do
for j:=1 to 7 do begin
write (a[i,j]:4);
end;
readkey;
end.
2) Массив заполняется автоматически:
Program Zamena5;
uses crt;
type m=array [1..7, 1..7] of integer;
var a: m;
i, j: integer;
begin
clrscr;
for i:=1 to 7 do
for j:=1 to 7 do begin
randomize;
a[i,j]:=random (100);
end;
writeln ('Был сгенерирован массив: ');
for i:=1 to 7 do
for j:=1 to 7 do begin
writeln (a[i,j]);
end;
for i:=1 to 7 do
for j:=1 to 7 do begin
if (i=j) and (a[i,j] mod 5 =0) then a[i,j]:=2*a[i,j];
end;
writeln ('Массив после замены чисел, кратных 5 на главной диагонали: ');
for i:=1 to 7 do
for j:=1 to 7 do begin
write (a[i,j]:4);
end;
readkey;
end.
				
							1) Ввод вручную с клавиатуры. После того, как набирается число, нужно нажать клавишу "Enter" (предупреждаю заранее: это долго вводить 49 чисел):
Program Zamena5;
uses crt;
type m=array [1..7, 1..7] of integer;
var a: m;
i, j: integer;
begin
clrscr;
for i:=1 to 7 do
for j:=1 to 7 do begin
write ('Введите ', a[i,j], ' элемент массива: ');
readln (a[i,j]);
end;
writeln ('Вы ввели следующий массив: ');
for i:=1 to 7 do
for j:=1 to 7 do begin
writeln (a[i,j]);
end;
for i:=1 to 7 do
for j:=1 to 7 do begin
if (i=j) and (a[i,j] mod 5 =0) then a[i,j]:=2*a[i,j];
end;
writeln ('Массив после замены чисел, кратных 5 на главной диагонали: ');
for i:=1 to 7 do
for j:=1 to 7 do begin
write (a[i,j]:4);
end;
readkey;
end.
2) Массив заполняется автоматически:
Program Zamena5;
uses crt;
type m=array [1..7, 1..7] of integer;
var a: m;
i, j: integer;
begin
clrscr;
for i:=1 to 7 do
for j:=1 to 7 do begin
randomize;
a[i,j]:=random (100);
end;
writeln ('Был сгенерирован массив: ');
for i:=1 to 7 do
for j:=1 to 7 do begin
writeln (a[i,j]);
end;
for i:=1 to 7 do
for j:=1 to 7 do begin
if (i=j) and (a[i,j] mod 5 =0) then a[i,j]:=2*a[i,j];
end;
writeln ('Массив после замены чисел, кратных 5 на главной диагонали: ');
for i:=1 to 7 do
for j:=1 to 7 do begin
write (a[i,j]:4);
end;
readkey;
end.
if (i=j) and (a(i,j) mod 5 =0) then a(i,j)=2*a(i,j)
				
							Похожие вопросы
- Информатика, решение задач на массивы
- Информатика, решение задач на массивы. Прошу срочно!!!
- ПОМОГИТЕ РЕШИТЬ ЗАДАЧИ "ОДНОМЕРНЫЕ МАССИВЫ" ПО ИНФОРМАТИКЕ ПОЖАЛУЙСТА БЫСТРЕЕ!. ЗА ПРАВИЛЬНЫЕ ОТВЕТЫ ЛАЙКАЮ
- Помогите решить задачу по информатике . Задача внутри
- Информатика задача паскаль
- Информатика 10-11 класс Массивы Pascal1
- Помогите решать задачу по Информатике 10класс
- Задача по информатике.
- Информатика, решение задач
- Помогите, пожалуйста, решить задачу по информатике.
 
			 
						