Напиши программу для решения следующей задачи:
Дан одномерный массив А, состоящий из 9 целых чисел. Найти произведение чисел, которые кратны 5. (по  Pascal)
	
	
	Домашние задания: Информатика
	
		
		
								
				
																				
							
								
				
								
				
																				
							
			
	
		
			Помогите построить программу по информатикен 9 класс
Заводите переменную, в которой будет текущее произведение, инициализируете его единицей.
Потом запускаете цикл, при каждой итерации смотрите, уж не делится ли текущее значение массива на пять без остатка? если да, делится, то текущее произведение домножаете на это текущее значение массива.
А в конце цикла просто выводите текущее произведение.
				
									Потом запускаете цикл, при каждой итерации смотрите, уж не делится ли текущее значение массива на пять без остатка? если да, делится, то текущее произведение домножаете на это текущее значение массива.
А в конце цикла просто выводите текущее произведение.
								
									Куляна Нуртазина								
								а как это сделать а построить программу?							
											Вопрос: как заполняется массив: вручную с клавиатуры или автоматически генератором случайных чисел? Ладно, напишу оба варианта:
1) Массив вводится с клавиатуры:
Program P1;
uses crt;
const n=9;
type massiv=array [1..n] of integer;
var m: massiv;
i, p: integer;
begin
clrscr;
p:=1;
for i:=1 to n do begin
write ('Введите ', i, '-й элемент массива: ');
readln (m[i]);
end;
for i:=1 to n do begin
if m[i] mod 5=0 then p:=p*m[i];
end;
write ('Произведение чисел, кратных 5, составляет: ', p);
readkey;
end.
2) Массив заполняется автоматически:
Program P1;
uses crt;
const n=9;
type massiv=array [1..n] of integer;
var m: massiv;
i, p: integer;
begin
clrscr;
p:=1;
for i:=1 to n do begin
randomize;
m[i]:=random (101);
end;
writeln ('Был сгенерирован массив:');
for i:=1 to n do begin
write (m[i], ' ');
end;
writeln (' ');
for i:=1 to n do begin
if m[i] mod 5=0 then p:=p*m[i];
end;
write ('Произведение чисел, кратных 5, составляет: ', p);
readkey;
end.
				
							1) Массив вводится с клавиатуры:
Program P1;
uses crt;
const n=9;
type massiv=array [1..n] of integer;
var m: massiv;
i, p: integer;
begin
clrscr;
p:=1;
for i:=1 to n do begin
write ('Введите ', i, '-й элемент массива: ');
readln (m[i]);
end;
for i:=1 to n do begin
if m[i] mod 5=0 then p:=p*m[i];
end;
write ('Произведение чисел, кратных 5, составляет: ', p);
readkey;
end.
2) Массив заполняется автоматически:
Program P1;
uses crt;
const n=9;
type massiv=array [1..n] of integer;
var m: massiv;
i, p: integer;
begin
clrscr;
p:=1;
for i:=1 to n do begin
randomize;
m[i]:=random (101);
end;
writeln ('Был сгенерирован массив:');
for i:=1 to n do begin
write (m[i], ' ');
end;
writeln (' ');
for i:=1 to n do begin
if m[i] mod 5=0 then p:=p*m[i];
end;
write ('Произведение чисел, кратных 5, составляет: ', p);
readkey;
end.
program mas_kr_5;
uses crt;
var s,k,i:integer;
a:array[1..9] of integer;
begin
for i:=1 to 9 do
begin write(' a[',i,'] = '); read(a[i]);
end; s:=1; writeln('massiw kratny 5');
for i:=1 to 9 do if a[i] mod 5 = 0 then write(a[i]:3);
for i:=1 to 9 do if a[i] mod 5 = 0 then s:=s*a[i];
writeln;
writeln(' proizwed. s = ',s);
end.
				
									uses crt;
var s,k,i:integer;
a:array[1..9] of integer;
begin
for i:=1 to 9 do
begin write(' a[',i,'] = '); read(a[i]);
end; s:=1; writeln('massiw kratny 5');
for i:=1 to 9 do if a[i] mod 5 = 0 then write(a[i]:3);
for i:=1 to 9 do if a[i] mod 5 = 0 then s:=s*a[i];
writeln;
writeln(' proizwed. s = ',s);
end.
								
									Куляна Нуртазина								
								Спасибо , лучший							
																				
								
									Куляна Нуртазина								
								Хорошо							
											Похожие вопросы
- Помогите пожалуйста!!! Очень срочно, информатика, 9 класс!!!
- Паскаль программа 9 класс
- Информатика 9 класс
- ПОМОГИТЕ С ИНФОРМАТИКОЙ 9 КЛАСС!
- Задание по информатике. 9 Класс
- Срочно Помогите написать программу по задаче (на любом языке программирования)
- Помогите с дз по информатике. Паскаль. 9 класс.
- Информатика 9 класс помогите пожалуйста!
- ИНФОРМАТИКА 9 КЛАСС ПОМОГИТЕ!
- Пожалуйста помогите решить информатика 9 класс
 
						