Другие языки программирования и технологии
Помогите написать простые программы и задачи в Pascal ABC. Алгоритмы ветвления. Информатика. Програмирование.
1. Ввести два числа А и В. Вывести сообщение "YES", если оба числа А и В являются отрицательными числами, в противном случае вывести сообщение "NO". 2. Туристы вышли из леса на шоссе неподалеку от километрового столба с отметкой А км и решили пойти на ближайшую автобусную остановку. Посмотрев на план местности руководитель группы сказал, что автобусные остановки расположены на километре В и С. Куда следует пойти туристам? 3. Кусок медного провода длиной 5 м имеет массу 430 г. Чтобы провести проводку в квартире требуется С метров. Хватит ли для этой цели мотка массой X г? 4. Написать программу, которая воодит значение промежутка времени между вспышкой молнии и раскатом грома. и определяет удаляется или приближается гроза? 5. Ввести два числа А и В. Вывести сообщение "OTR", если оба числа А и В являются отрицательными числами, вывести сообщение "POL", если оба числа имеют разные знаки. Поможите? ^^ Заранее благодарю (:
Задача №1.
var a,b:integer;
begin
writeln('Введите a и b:');
write('a=');
readln(a);
write('b=');
readln(b);
if (a<0) and (b<0) then writeln('YES')
else writeln('NO');
end.
Задача №2 (Насчет того что программа написана правильно сомневаюсь)
Var a,b,c:real;
begin
writeln('Введите A, В и С: ');
write('A=');
readln(a);
write('B=');
readln(b);
write('C=');
readln(c);
if (b-a)<(c-a) then writeln('До остановки В')
else if(b-a)>(c-a) then writeln('До остановки С')
else writeln('Расстояние до остановок одинаковое');
end.
Задача №3
Var c,x,a,b,d:real;
begin
writeln('Введите c и x:');
write('c=');
readln(c);
write('x=');
readln(x);
a:=5/430;
b:=c/x;
d:=a-b;
if d<0 then writeln('Не хватит')
else writeln('Хватит');
end.
Задача №5
Var a,b:real;
begin
writeln('Введите А и В: ');
write('a=');
readln(a);
write('b=');
readln(b);
if (a<0) and (b<0) then writeln('ORT')
else if (a*b<0) then writeln('POL')
else writeln('Числа А и В являются положительными числами');
end.
var a,b:integer;
begin
writeln('Введите a и b:');
write('a=');
readln(a);
write('b=');
readln(b);
if (a<0) and (b<0) then writeln('YES')
else writeln('NO');
end.
Задача №2 (Насчет того что программа написана правильно сомневаюсь)
Var a,b,c:real;
begin
writeln('Введите A, В и С: ');
write('A=');
readln(a);
write('B=');
readln(b);
write('C=');
readln(c);
if (b-a)<(c-a) then writeln('До остановки В')
else if(b-a)>(c-a) then writeln('До остановки С')
else writeln('Расстояние до остановок одинаковое');
end.
Задача №3
Var c,x,a,b,d:real;
begin
writeln('Введите c и x:');
write('c=');
readln(c);
write('x=');
readln(x);
a:=5/430;
b:=c/x;
d:=a-b;
if d<0 then writeln('Не хватит')
else writeln('Хватит');
end.
Задача №5
Var a,b:real;
begin
writeln('Введите А и В: ');
write('a=');
readln(a);
write('b=');
readln(b);
if (a<0) and (b<0) then writeln('ORT')
else if (a*b<0) then writeln('POL')
else writeln('Числа А и В являются положительными числами');
end.
Ты бы еще весь задачник выложил...
1. Ввести два числа А и В. Вывести сообщение "YES", если оба числа А и В являются отрицательными числами, в противном случае вывести сообщение "NO".
readln(a);
readln(b);
if (a<0)and(b<0) then writeln('YES') else writeln('NO');
5. Ввести два числа А и В. Вывести сообщение "OTR", если оба числа А и В являются отрицательными числами, вывести сообщение "POL", если оба числа имеют разные знаки.
readln(a);
readln(b);
if (a<0)and(b<0) then writeln('ORT')
else if (a*b<0) then writeln('POL')
else writeln('ХЗ чё надо в этом случае');
readln(a);
readln(b);
if (a<0)and(b<0) then writeln('YES') else writeln('NO');
5. Ввести два числа А и В. Вывести сообщение "OTR", если оба числа А и В являются отрицательными числами, вывести сообщение "POL", если оба числа имеют разные знаки.
readln(a);
readln(b);
if (a<0)and(b<0) then writeln('ORT')
else if (a*b<0) then writeln('POL')
else writeln('ХЗ чё надо в этом случае');
Я тебе оставлю свой паблик, где я публикую программы на паскале, заходи, смотри, подписывайся)) https://vk.com/public137401359
https://vk.com/public137401359
https://vk.com/public137401359
https://vk.com/public137401359
https://vk.com/public137401359
Похожие вопросы
- Напишите программу к задаче в Pascal abc. Необходимо ввести три целых числа и определить, какое из них
- помогите написать простые программы на Qbasic
- помогите с задачей по Pascal abc!!!
- Помогите написать 2 программы в Pascal ABC
- Помогите с задачей на Pascal ABC
- Помогите пожалуйста решить задачу в Pascal ABC
- Помогите с составлением задач в Pascal ABC!!Срочно!
- Задача ферзей. Pascal abc
- Напишите какие нибудь интересные картинки для Pascal ABC.
- Помогите написать 2 программы на языке pascal!