Другие языки программирования и технологии

Очень срочно!!! Помогите с заданиями по ИНФОРМАТИКЕ, надо написать несколько программ:

Задача 1

Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры

Задача 2

Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран

Задача 3

Напишите программу которая при вводе пяти чисел вычисляла бы их сумму и произведение, и выводила на экран, что из этого больше.

Задача 4

Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры

Задача 5

Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран

Задача 6

Напишите программу которая при вводе пяти чисел вычисляла бы их сумму и произведение, и выводила на экран, что из этого больше.

Задача 7

Напишите программу которая при воде с клавиатуры трёх чисел, найдет наибольшее из них.
Решение на Pascal ABC (Turbo Pascal)
задача №1

var x: integer;
begin
writeln ('введите число');
while x<=0 do
begin
write ('x=');
read (x);
if x < 0 then writeln (' это число отрицательное ');
if x = 0 then writeln (' это число "нуль" ');
end;
writeln (x, ' - число положительное ');
end.

Задача №2

var x, y: integer;
begin
writeln ('введите 1-е число ');
read (x);
writeln ('введите 2-е число ');
repeat
read (y);
until y <> x;
if x > y then writeln (' число ', x, ' больше ', y)
else writeln (' число ', y, ' больше ', x)
end.

Задача №7
var i, max, x: integer;
begin
i:=1;
while i<=3 do
begin
write (' x = ');
readln (x);
if i=1 then
max:=x;
if x>max then max:=x;
inc (i);
end;
writeln;
writeln ('maximum ', max);
end.

Задача №6
var i, sum, x, pro: integer;
begin
i:=1;
sum:=0;
pro:=1;
while i<=5 do
begin
write (' x',i,' = ');
readln (x);
pro:=pro*x;
sum:=sum+x;
inc (i);
end;
writeln;
if sum > pro then writeln ('summa > proizv')
else writeln ('proizv > summa');
end.
МГ
Мухамедкарим Газизов
24 309
Лучший ответ
1) int x; cin >> x; cout << (x>0)?"да":"нет";
2) int x,y; cin >> x >> y; cout << (x>y)?x:y;
3) int a,s=0,m=1; for ( int i=0; i < 5; i++ ) { cin>>a; s+=a;m*=a; } cout (s>m)?s:m;
RI
Rafael Iskanderov
27 070
Namik Mamedov Только этой пизде похоже паскаль надо...
Игорь Репный Если ПАСКАЛЬ, пришли свою почту, помогу