Использовать цикл и массив!
1. С клавиатуры вводится число n -количество человек. Затем n чисел-рост этих людей. Вывести на экран рост наибольшего.
2. С клавиатуры вводитсяn-количество чисел, затем n чисел. Вывести количество чисел, кратных 2
3. С клавиатуры вводится 10 чисел-возраст людей, вывести даты из рождения
	
	
	Домашние задания: Информатика
	
		
		
								
				
								
				
																				
							
			
	
		
			Помогите сделать программы Паскаль!
program Murzin;
var
a: array of byte;
n: byte;
begin
// 1)
writeln('Задание №1:', #10,
'С клавиатуры вводится число n - количество человек. Затем n чисел - рост этих людей. Вывести на экран рост наибольшего.');
var max: byte;
write('Введите n: ');
readln(n);
setLength(a, n);
writeln('Вводите рост людей (не более 255):');
for var i := 0 to n-1 do begin
write(i+1, ' человек: ');
read(a[i]);
if a[i] > max then max := a[i];
end;
writeln('Максимальный рост: ', max);
 
// 2)
writeln('Задание №2:', #10,
'С клавиатуры вводится n - количество чисел, затем n чисел. Вывести количество чисел, кратных 2.');
var count: byte;
write('Введите n: ');
readln(n);
setLength(a, n);
writeln('Вводите числа (от 0 до 255):');
for var i := 0 to n-1 do begin
write(i+1, ' число: ');
read(a[i]);
if a[i] mod 2 = 0 then count += 1;
end;
writeln('Количество чисел, кратных двум: ', count);
 
// 3)
writeln('Задание №3:', #10,
'С клавиатуры вводится 10 чисел - возраст людей, вывести даты их рождения.');
setLength(a, 10);
writeln('Вводите возраст людей:');
for var i := 0 to 9 do begin
write(i+1, ' человек: ');
read(a[i]);
writeln('Год рождения: ', 2019 - a[i], ' или ', 2019 - a[i] - 1);
end;
end.
				
									var
a: array of byte;
n: byte;
begin
// 1)
writeln('Задание №1:', #10,
'С клавиатуры вводится число n - количество человек. Затем n чисел - рост этих людей. Вывести на экран рост наибольшего.');
var max: byte;
write('Введите n: ');
readln(n);
setLength(a, n);
writeln('Вводите рост людей (не более 255):');
for var i := 0 to n-1 do begin
write(i+1, ' человек: ');
read(a[i]);
if a[i] > max then max := a[i];
end;
writeln('Максимальный рост: ', max);
// 2)
writeln('Задание №2:', #10,
'С клавиатуры вводится n - количество чисел, затем n чисел. Вывести количество чисел, кратных 2.');
var count: byte;
write('Введите n: ');
readln(n);
setLength(a, n);
writeln('Вводите числа (от 0 до 255):');
for var i := 0 to n-1 do begin
write(i+1, ' число: ');
read(a[i]);
if a[i] mod 2 = 0 then count += 1;
end;
writeln('Количество чисел, кратных двум: ', count);
// 3)
writeln('Задание №3:', #10,
'С клавиатуры вводится 10 чисел - возраст людей, вывести даты их рождения.');
setLength(a, 10);
writeln('Вводите возраст людей:');
for var i := 0 to 9 do begin
write(i+1, ' человек: ');
read(a[i]);
writeln('Год рождения: ', 2019 - a[i], ' или ', 2019 - a[i] - 1);
end;
end.
Описание массива
var massiv:array[1..maxindex] of type; где maxindex - число элементов а type как несложно догадаться тип элементов.
Цикл вам тут подойдет со счетчиком
for i:=min to max do тело цикла
Здесь переменная i - счетчик который проходит по циклу от min до max значение.
				
									var massiv:array[1..maxindex] of type; где maxindex - число элементов а type как несложно догадаться тип элементов.
Цикл вам тут подойдет со счетчиком
for i:=min to max do тело цикла
Здесь переменная i - счетчик который проходит по циклу от min до max значение.
								
									Любовь Комелькова								
								Сама программа?							
											Похожие вопросы
- Короче, помогите написать программу на языке паскаля где нужно--->
- Помогите на Pascal сделать программу, которая считает количество дней до лета.
- Помогите срочно!!!!Информатика ПАСКАЛЬ
- Срочно Помогите написать программу по задаче (на любом языке программирования)
- Помогите с информатикой (паскаль)
- ПОМОГИТЕ !!!!ИНФОРМАТИКА СРОЧНО!!! ПАСКАЛЬ
- ПОМОГИТЕ СРОЧНО!! ИНФОРМАТИКА ПАСКАЛЬ!!
- Помогите с инфой. Паскаль
- Помогите построить программу по информатикен 9 класс
- Умоляю помогите с программой
 
			 
						
Ну измени на integer, вырежи каждое задание в отдельный файл.. Размышляй, пробуй..