Домашние задания: Информатика

Умоляю помогите с программой

Нужно написать программу, которая рассчитает, из скольки символов состоит введенное с клавиатуры предложение. И посчитает скольки среди них согласных
Program P1;
uses crt;
var i, l, s: integer;
st: string;
begin
clrscr;
writeln ('Введите предложение (в строку), после чего нажмите клавишу Enter.');
write ('Введите предложение: ');
readln (st);
l:=length (st);
s:=0;
for i:=1 to length (st) do begin
if (st[i]='Б') or (st[i]='В') or (st[i]='Г') or (st[i]='Д') or (st[i]='Ж') or (st[i]='З') then s:=s+1;
if (st[i]='Й') or (st[i]='К') or (st[i]='Л') or (st[i]='М') or (st[i]='Н') or (st[i]='П') then s:=s+1;
if (st[i]='Р') or (st[i]='С') or (st[i]='Т') or (st[i]='Ф') or (st[i]='Х') or (st[i]='Ц') then s:=s+1;
if (st[i]='Ч') or (st[i]='Ш') or (st[i]='Щ') then s:=s+1;

if (st[i]='б') or (st[i]='в') or (st[i]='г') or (st[i]='д') or (st[i]='ж') or (st[i]='з') then s:=s+1;
if (st[i]='й') or (st[i]='к') or (st[i]='л') or (st[i]='м') or (st[i]='н') or (st[i]='п') then s:=s+1;
if (st[i]='р') or (st[i]='с') or (st[i]='т') or (st[i]='ф') or (st[i]='х') or (st[i]='ц') then s:=s+1;
if (st[i]='ч') or (st[i]='ш') or (st[i]='щ') then s:=s+1;

if (st[i]='B') or (st[i]='C') or (st[i]='D') or (st[i]='F') or (st[i]='G') or (st[i]='H') then s:=s+1;
if (st[i]='J') or (st[i]='K') or (st[i]='L') or (st[i]='M') or (st[i]='N') or (st[i]='P') then s:=s+1;
if (st[i]='Q') or (st[i]='R') or (st[i]='S') or (st[i]='T') or (st[i]='V') or (st[i]='W') then s:=s+1;
if (st[i]='X') or (st[i]='Z') then s:=s+1;

if (st[i]='b') or (st[i]='c') or (st[i]='d') or (st[i]='f') or (st[i]='g') or (st[i]='h') then s:=s+1;
if (st[i]='j') or (st[i]='k') or (st[i]='l') or (st[i]='m') or (st[i]='n') or (st[i]='p') then s:=s+1;
if (st[i]='q') or (st[i]='r') or (st[i]='s') or (st[i]='t') or (st[i]='v') or (st[i]='w') then s:=s+1;
if (st[i]='x') or (st[i]='z') then s:=s+1;
end;
writeln ('Введенное предложение состоит из ',l, ' символов.');
writeln ('В введенном предложении ', s, ' согласных букв.');
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
end.
Алёна Ведибеда
Алёна Ведибеда
43 559
Лучший ответ
а язык программирования какой?
Александра Железнякова Паскаль прошу помоги иначе мне конец
Александра Железнякова Так ты поможешь мне?