Другие языки программирования и технологии
Вопрос к программистам. Легкая задачка по информатике на языке Паскаль.
Создать массив, состоящий из 10 целых случайных чисел,вывести на экран массив. Вывести на экран элементы массива,которые делятся на 3 сколько таких элементов в массиве? подсчитать сумму всех элементов массива, стоящих на четных местах. Очень нужно решить, контрольную на дом дали
Я вам уверяю в наше время вам Паскаль не к чему в жизни не приведет!
Программирование надо изучать только современное. Так вот изучайте Delphi и т. д. хотя на Перле учили вас что-ли7
1. -= Решение =-
Составить программу для вычисления S. Задачу решить тремя способами (с использованием трех типов оператора цикла) .
Вычислить:
S:=xn/n!+xn-1/(n-1)!+..+x1/1!
2. это на вывод в экран то-есть пользователь ведет в итоге. -=Pascal=-
program summa;
uses Crt;
var A: array[1..10] of integer;
s: integer;
i: integer;
begin
ClrScr;
FOR I:=1 to 10 do
begin
WriteLn ('Введи число №', i);
ReadLn(A);
end;
FOR I:=1 to 10 do
begin
Write (A);
Write(' ');
end;
s:=0;
FOR I:=1 to 10 do
S:=S+A;
WriteLn;
WriteLn ('Сумма чисел: ', s);
end.
Программирование надо изучать только современное. Так вот изучайте Delphi и т. д. хотя на Перле учили вас что-ли7
1. -= Решение =-
Составить программу для вычисления S. Задачу решить тремя способами (с использованием трех типов оператора цикла) .
Вычислить:
S:=xn/n!+xn-1/(n-1)!+..+x1/1!
2. это на вывод в экран то-есть пользователь ведет в итоге. -=Pascal=-
program summa;
uses Crt;
var A: array[1..10] of integer;
s: integer;
i: integer;
begin
ClrScr;
FOR I:=1 to 10 do
begin
WriteLn ('Введи число №', i);
ReadLn(A);
end;
FOR I:=1 to 10 do
begin
Write (A);
Write(' ');
end;
s:=0;
FOR I:=1 to 10 do
S:=S+A;
WriteLn;
WriteLn ('Сумма чисел: ', s);
end.
Задача реально дет сад!
Зачем вы учитесь? подойдите к преподу и скажите что вам в вашей будующей професии дворника или грузчика паскаль нафиг ненадо и пусть он не мучает ни себя ни вас!
Зачем вы учитесь? подойдите к преподу и скажите что вам в вашей будующей професии дворника или грузчика паскаль нафиг ненадо и пусть он не мучает ни себя ни вас!
program p;
uses Crt;
var
a:array[1..10] of unteger;
i:integer;
c:integer;
n:integer;
begin
randomize;
for i:=1 to 10 do begin a:=random(10)+1;
write(a,' ');
end;
writeln;
for i:=1 to 10 do begin if mod(a)=0 then write(a,' '); c:=c+1;
if mod(i)=0 then n:=n+1;
end;
writeln;
write('Na 3 delica ',c,'4isel');
end;
uses Crt;
var
a:array[1..10] of unteger;
i:integer;
c:integer;
n:integer;
begin
randomize;
for i:=1 to 10 do begin a:=random(10)+1;
write(a,' ');
end;
writeln;
for i:=1 to 10 do begin if mod(a)=0 then write(a,' '); c:=c+1;
if mod(i)=0 then n:=n+1;
end;
writeln;
write('Na 3 delica ',c,'4isel');
end;
вау, я уже и не помню...: (((((((((в том году такое же было.
массив заполнишь сам. продолжение на С++
int counter; // объявляем переменную-счётчик. которая будет считать элементы которые делятся на 3
int sum=0;
// массив, например называется a, c n элементами. тоесть a[n]
for(int i=0; i<n;>%3==0)
{
counter++;
//тут выводишь на экран элемент а, можно ещё пробел отступить
}
if((i+1)%2==0)
sum=sum+a;
}
после цикла выводишь counter в котором сохранено кол-во переменных которые делятся на 3
и переменную sum, в котрой сохранена сумма всех элементов которые стоят на чётных позициях
int counter; // объявляем переменную-счётчик. которая будет считать элементы которые делятся на 3
int sum=0;
// массив, например называется a, c n элементами. тоесть a[n]
for(int i=0; i<n;>%3==0)
{
counter++;
//тут выводишь на экран элемент а, можно ещё пробел отступить
}
if((i+1)%2==0)
sum=sum+a;
}
после цикла выводишь counter в котором сохранено кол-во переменных которые делятся на 3
и переменную sum, в котрой сохранена сумма всех элементов которые стоят на чётных позициях
Хмм.. . как же меня ДОСТАЛИ Ламеры, нубы, наглые люди и школота необразованная.!! !
ИТАК!
1. Какого ТЫ пошел на программиста?? ! Если ты даже НЕ стремишься стать профессиональным программистом!
2. Одно из двух или ты пошел, т. к. родители ЗАСТАВИЛИ, а ты молча согласился гробя свою жизнь, потому что это не твое ИЛИ ты пошел ради диплома.. . если диплом... то запомни.. прийдешь на работу, дадут задание и ты его провалишь и полетишь с грохотом с той работы!
3. Ты читаешь книги по прикладному программированию? Или ты решил, что за тебя другие будут учиться? Пойми, если основы пропустишь, то даьше можно не учиться, так как не сможешь ничего решать! И будешь ты давать, давать много денег, чтобы тебе оценочку поставили ...эхх. . такая жизнь парень.. .
Если ты НЕ хочешь стать хорошим программистом, ТО КИДАЙ ЭТО ДЕЛО! Пока не поздно....
ИТАК!
1. Какого ТЫ пошел на программиста?? ! Если ты даже НЕ стремишься стать профессиональным программистом!
2. Одно из двух или ты пошел, т. к. родители ЗАСТАВИЛИ, а ты молча согласился гробя свою жизнь, потому что это не твое ИЛИ ты пошел ради диплома.. . если диплом... то запомни.. прийдешь на работу, дадут задание и ты его провалишь и полетишь с грохотом с той работы!
3. Ты читаешь книги по прикладному программированию? Или ты решил, что за тебя другие будут учиться? Пойми, если основы пропустишь, то даьше можно не учиться, так как не сможешь ничего решать! И будешь ты давать, давать много денег, чтобы тебе оценочку поставили ...эхх. . такая жизнь парень.. .
Если ты НЕ хочешь стать хорошим программистом, ТО КИДАЙ ЭТО ДЕЛО! Пока не поздно....
стучи в агент, скину учебников
Похожие вопросы
- Информатика. Delphi (язык "Паскаль"). Помогите с матрицей, а то до автомата-тройки (ну, как бы экзамена) не допустят
- Хочу пойти на программиста. Нужно начинать писать программы на языке Паскаль ?
- Еще вопросы к программистам :)...точнее задачки...
- Помощь по информатике. 9 класс. Программирование .Язык Паскаль. Ветвление
- помогите решить задачку по информатике на паскале. найти минимальный и максимальный элемент двухмерного массива
- Помогите решить задачу по информатике. Массивы. Язык программирования Паскаль.
- Помогите, пожалуйста, с информатикой. 10 класс. Надо найти ошибку в программе. Язык паскаль
- Информатики, выручайте, любые 5 заданий, пожалуйста!!! Нужно написать программу на языке паскаль.
- Помогите записать на языке паскаля.
- Нужны программы на языке Паскаль