Другие языки программирования и технологии
Помогите срочно!!! По информатике Паскаль!!!
Напишите программу которая в последовательности натуральных чисел находит среднее арифметическое трехзначных чисел или сообщает что таких чисел нет. Последовательность чисел заканчивается числом 0( 0 - признак окончания ввода, не является частью последовательности). Колво чисел не превышает 300.Введенные числа по модулю не превышают 500
вариант под твою задачу с соблюдением всех условий
uses crt;
var chislo, i, k: integer;
summa: real;
const n=300; {количество чисел}
m=500;
begin
randomize;
clrscr;
k:=0;
summa:=0;
i:=0;
chislo:= random (m)-random (m); {первое число наугад}
repeat
chislo:=chislo+1;
if (abs(chislo) >99) and (abs(chislo)<1000) then
begin
k:=k+1;
summa:=summa+chislo;
textcolor (green);
write (chislo:8);
end
else
begin
textcolor (white);
write (chislo:8);
end;
if (chislo=0) and (k=0) then
begin
textcolor (white);
writeln;
write ('Чисел нет');
break;
end;
i:=i+1;
until (chislo <>0) and (i>n-1);
writeln;
textcolor (white);
if k>0 then
begin
writeln ('Чисел трехзначных, шт. =', k);
writeln ('Среднее арифметическое значение=', summa / k:3:3);
end;
readln;
end.
второй вариант решения, считаю что все числа должны быть наугад
uses crt;
var chislo, i, k: integer;
summa: real;
const n=300; {количество чисел}
m=500;
begin
randomize;
clrscr;
k:=0;
summa:=0;
i:=0;
repeat
chislo:= random (m)-random (m); {числа наугад}
if (abs(chislo) >99) and (abs(chislo)<1000) then
begin
k:=k+1;
summa:=summa+chislo;
textcolor (green);
write (chislo:8);
end
else
begin
textcolor (white);
write (chislo:8);
end;
if (chislo=0) and (k=0) then
begin
textcolor (white);
writeln;
write ('Чисел нет');
break;
end;
i:=i+1;
until (chislo <>0) and (i>n-1);
writeln;
textcolor (white);
if k>0 then
begin
writeln ('Чисел трехзначных, шт. =', k);
writeln ('Среднее арифметическое значение=', summa / k:3:3);
end;
readln;
end.
uses crt;
var chislo, i, k: integer;
summa: real;
const n=300; {количество чисел}
m=500;
begin
randomize;
clrscr;
k:=0;
summa:=0;
i:=0;
chislo:= random (m)-random (m); {первое число наугад}
repeat
chislo:=chislo+1;
if (abs(chislo) >99) and (abs(chislo)<1000) then
begin
k:=k+1;
summa:=summa+chislo;
textcolor (green);
write (chislo:8);
end
else
begin
textcolor (white);
write (chislo:8);
end;
if (chislo=0) and (k=0) then
begin
textcolor (white);
writeln;
write ('Чисел нет');
break;
end;
i:=i+1;
until (chislo <>0) and (i>n-1);
writeln;
textcolor (white);
if k>0 then
begin
writeln ('Чисел трехзначных, шт. =', k);
writeln ('Среднее арифметическое значение=', summa / k:3:3);
end;
readln;
end.
второй вариант решения, считаю что все числа должны быть наугад
uses crt;
var chislo, i, k: integer;
summa: real;
const n=300; {количество чисел}
m=500;
begin
randomize;
clrscr;
k:=0;
summa:=0;
i:=0;
repeat
chislo:= random (m)-random (m); {числа наугад}
if (abs(chislo) >99) and (abs(chislo)<1000) then
begin
k:=k+1;
summa:=summa+chislo;
textcolor (green);
write (chislo:8);
end
else
begin
textcolor (white);
write (chislo:8);
end;
if (chislo=0) and (k=0) then
begin
textcolor (white);
writeln;
write ('Чисел нет');
break;
end;
i:=i+1;
until (chislo <>0) and (i>n-1);
writeln;
textcolor (white);
if k>0 then
begin
writeln ('Чисел трехзначных, шт. =', k);
writeln ('Среднее арифметическое значение=', summa / k:3:3);
end;
readln;
end.
Написал:
.

.

Виталий Петров
там без crt надо
Виталий Петров
я имел ввиду то что вы написали в паскале
Помогаю:
— описываешь переменные;
— открываешь операторные скобки;
— задаёшь начальные значения и открываешь цикл;
и т. д.
Сделать за тебя — цена вопроса?
— описываешь переменные;
— открываешь операторные скобки;
— задаёшь начальные значения и открываешь цикл;
и т. д.
Сделать за тебя — цена вопроса?
Виталий Петров
Сделай пожалуйста

Sergey Gorbatkoff
Абсолютно правильно!
0
Я тоже напишу что-нибудь. -)
Готово:
Работы максимум минут на 10.

Работы максимум минут на 10.

Самат Дюсеков
program zadachka;
var i, x, sum: integer;
begin
repeat
Write('Введите число: ');
Read(i);
if (i < 1000) and (i>99) then
begin
sum:=sum + i;
x:= x+1;
end;
until i=0;
if x = 0 then Writeln('Трёхзначных чисел не найдено')
else Writeln('Среднее арифметическое: ',sum/x);
end.
var i, x, sum: integer;
begin
repeat
Write('Введите число: ');
Read(i);
if (i < 1000) and (i>99) then
begin
sum:=sum + i;
x:= x+1;
end;
until i=0;
if x = 0 then Writeln('Трёхзначных чисел не найдено')
else Writeln('Среднее арифметическое: ',sum/x);
end.
s
Похожие вопросы
- Помогите пожалуйста решить информатику, Паскаль.
- Помогите, пожалуйста... Курс информатики, 9 класс. В паскале вообще ничего не понимаю((
- ПОМОГИТЕ ОЧЕНЬ СРОЧНО!! ИНФОРМАТИКА!!!ПАСКАЛЬ
- Паскаль написать программу помогите. срочно. Пожалуйста
- Информатика.Практическая работа по паскалю.ПОМОГИТЕ.Все нужно ввиде паскаля.мучаюсь целый день.постоянно какие-то ошибки
- СРОЧНО ПОМОГИТЕ!!! Напишите прогу на паскале
- Помогите с программой в Паскале, срочно!
- Задачи по информатике паскаль
- Помогите пожалуйста найти ошибку в решении задачи по информатике(паскаль) !!!Прошу очень нужно!!!задача простая!!!
- Помогите решить задачу по информатике ...паскаль