Носир
Носир

Поле объекта не обнаружено (Номенклатура) . Подскажите, где допустил ошибку?!

&НаКлиенте
Процедура Сформировать (Команда)
СформироватьОтчет (ТабДок, ДатаОтчета) ;
КонецПроцедуры

&НаСервереБезКонтекста
Процедура СформироватьОтчет (ТабДок, ДатаОтчета)

Макет = Отчеты. ОстаткиТоваров. ПолучитьМакет ("Макет");
ОблШапка = Макет. ПолучитьОбласть ("ОблШапка");
ОблСтрока = Макет. ПолучитьОбласть ("ОблСтрока");

ТабДок. Очистить ();

ОблШапка. Параметры. ДатаОтчета = ДатаОтчета;

ТабДок. Вывести (ОблШапка) ;
Запрос = Новый Запрос;
Запрос. Текст =
"ВЫБРАТЬ
| Номенклатура,
| КоличествоОстаток
|ИЗ
| РегистрНакопления. ОстаткиТоваров. Остатки (&ДатаОтчета, )" ;


Запрос. УстановитьПараметр ("ДатаОтчета", ДатаОтчета) ;

Результат = Запрос. Выполнить ();

Выборка = Результат. Выбрать ();
Пока Выборка. Следующий () Цикл
ОблСтрока. Параметры. Номенклатура = Выборка. Номенклатура;
ОблСтрока. Параметры. Количество = Выборка. КоличествоОстаток;

ТабДок. Вывести (ОблСтрока) ;
КонецЦикла;
КонецПроцедуры

Дмитрий Головкин

А у тебя в конфе точно есть регистр ОстаткиТоваров и у него есть реквизит Номенклатура…
Либо попробуй воспользоваться псевдонимами (КАК)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Вообще, на ИТС диске есть Консоль запросов.

Вот в ней и отлаживай свои запросы. Потом только их в пофигуратор…

Другие вопросы из категории «Другие языки и технологии»

Помогите с домашним заданием по информатике на тему "операторы повторения"
Очень срочно надо. Укажите значение переменной s,которое соответствует результату выполнения указания команды повторений:
Народ кто шарит в реесторе Виндовс Помогите!!!
Помогите залить значки в цвет фона.
delphi xe3 как создать новые вкладки?
Какой программой спроектированы дома?
Как записать диск с образом востановления Windows
Вопрос программистам проблема с DHCP
Определит ли фаервол атаку ARP spoofing если она будет проводится внутри шлюза, т. е. непосредственно в лане?
двумерный массив с++ builder a= 3 2 1 (произвольные числа) b= 3 5 2 c= 9 10 7 ( вот так должна решить программа )