Поле объекта не обнаружено (Номенклатура) . Подскажите, где допустил ошибку?!

&НаКлиенте
Процедура Сформировать (Команда)
СформироватьОтчет (ТабДок, ДатаОтчета) ;
КонецПроцедуры

&НаСервереБезКонтекста
Процедура СформироватьОтчет (ТабДок, ДатаОтчета)

Макет = Отчеты. ОстаткиТоваров. ПолучитьМакет ("Макет");
ОблШапка = Макет. ПолучитьОбласть ("ОблШапка");
ОблСтрока = Макет. ПолучитьОбласть ("ОблСтрока");

ТабДок. Очистить ();

ОблШапка. Параметры. ДатаОтчета = ДатаОтчета;

ТабДок. Вывести (ОблШапка) ;
Запрос = Новый Запрос;
Запрос. Текст =
"ВЫБРАТЬ
| Номенклатура,
| КоличествоОстаток
|ИЗ
| РегистрНакопления. ОстаткиТоваров. Остатки (&ДатаОтчета, )" ;


Запрос. УстановитьПараметр ("ДатаОтчета", ДатаОтчета) ;

Результат = Запрос. Выполнить ();

Выборка = Результат. Выбрать ();
Пока Выборка. Следующий () Цикл
ОблСтрока. Параметры. Номенклатура = Выборка. Номенклатура;
ОблСтрока. Параметры. Количество = Выборка. КоличествоОстаток;

ТабДок. Вывести (ОблСтрока) ;
КонецЦикла;
КонецПроцедуры

Здесь легко и интересно общаться. Присоединяйся!

А у тебя в конфе точно есть регистр ОстаткиТоваров и у него есть реквизит Номенклатура…
Либо попробуй воспользоваться псевдонимами (КАК)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Вообще, на ИТС диске есть Консоль запросов.

Вот в ней и отлаживай свои запросы. Потом только их в пофигуратор…