Напишите программу на паскале
(a²-2ab+b²) a²
Домашние задания: Информатика
Помогите с паскалем
Никогда не писал на Паскале, ибо хрень редкостная. Поэтому держи код мейден ин chatGPT, но выводит он всё правильно, если судить по формулам:
program Expression;
var
a, b, result: real;
begin
write('Введите значение a: ');
readln(a);
write('Введите значение b: ');
readln(b);
result := (sqr(a) - 2 * a * b + sqr(b)) * sqr(a);
writeln('Результат: ', result:0:2);
readln;
end.
Сергей Власов
Ну раз не писАл никогда - значит, необязательно засорять интернет копированием сомнительных результатов за нейросетью. Особенно всякими топорными кодами (и не всегда правильными).
...
x:=sqr(a*(a-b));
...
x:=sqr(a*(a-b));
...
Я, пожалуй, немного сокращу задание, ибо в нём виден квадрат разности, но в конце напишу именно по заданию.
Итак, вот программа:
Итак, вот программа:
Program P1;
uses crt;
var a, b: real;
begin
clrscr;
writeln ('Введите с клавиатуры значения переменных a и b (только числа), после ввода значения каждой из переменных нажимайте клавишу Enter. При вводе дробных значений целую часть от дробной отделяйте точкой, а не запятой.');
write ('Введите значение переменной a: a=');
readln (a);
write ('Введите значение переменной b: b=');
readln (b);
writeln ('Результат: ', sqr (a-b)*sqr (a) :0:2);
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end. Ну а вот, если формулу не сокращать, а чисто по заданию, то вот: Program P1;
uses crt;
var a, b: real;
begin
clrscr;
writeln ('Введите с клавиатуры значения переменных a и b (только числа), после ввода значения каждой из переменных нажимайте клавишу Enter. При вводе дробных значений целую часть от дробной отделяйте точкой, а не запятой.');
write ('Введите значение переменной a: a=');
readln (a);
write ('Введите значение переменной b: b=');
readln (b);
writeln ('Результат: ', (sqr (a)-2*a*b+sqr (b))*sqr(a) :0:2);
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end. Похожие вопросы
- Помогите информатика паскаль!
- Помогите с паскалем, девятый класс
- Написать программы с помощью паскаля. Срочно помогите!
- Помогите с дз по информатике. Паскаль. 9 класс.
- Помогите пожалуйста нужно написать программу в паскале.
- Помогите срочно!!!!Информатика ПАСКАЛЬ
- Помогите пожалуйста с информатикой! (паскаль)
- Помогите с информатикой срочно! блок схемы, паскаль
- Короче, помогите написать программу на языке паскаля где нужно--->
- Помогите Христа ради! Язык программирования паскаль! Нужно составить программы! Помогите, пожалуйста, а то меня убьют!