Домашние задания: Информатика
	
		
		
								
				
																				
							
			
	
		
			Pascal, Информатика 7 класс
Дан массив из n чисел. Удалить все положительные элементы массива
	
	
	Смотря, что понимать под словом "дан" - если как константа - то где сам массив? И смотря, что понимать под словом "удалить"? Заменить на "0"? Если да и если же он вводится вручную с клавиатуры, то вот программа:
				
									 Program P1; 
uses crt; 
const n=5; 
type mas=array [1..n] of real; 
var i: byte; 
    m: mas; 
begin 
clrscr; 
writeln ('Заполните массив числами с клавиатуры. После ввода каждого из чисел нажимайте клавишу Enter. При вводе дробных значений целую часть от дробной отделяйте точкой, а не запятой.'); 
for i:=1 to n do begin 
    write ('Введите ', i, '-й элемент массива: '); 
    readln (m[i]); 
    end; 
write ('Вы ввели массив:'); 
for i:=1 to n do write (' ', m[i]); 
writeln (' '); 
for i:=1 to n do if m[i]>0 then m[i]:=0; 
write ('Преобразованный массив:'); 
for i:=1 to n do write (' ', m[i]); 
writeln (' '); 
write ('Программа завершена. Для выхода нажмите клавишу Enter.'); 
readkey; 
end. Если же массив заполняется автоматически при помощи генератора случайных чисел: Program P1; 
uses crt; 
const n=5; 
type mas=array [1..n] of integer; 
var i: byte; 
    m: mas; 
begin 
clrscr; 
for i:=1 to n do m[i]:=random (201)-100; 
write ('Был сгенерирован массив:'); 
for i:=1 to n do write (' ', m[i]); 
writeln (' '); 
for i:=1 to n do if m[i]>0 then m[i]:=0; 
write ('Преобразованный массив:'); 
for i:=1 to n do write (' ', m[i]); 
writeln (' '); 
write ('Программа завершена. Для выхода нажмите клавишу Enter.'); 
readkey; 
end. 
								
									Александр Мамойлов								
								Спасибо тебе ещё раз Дмитрий! Задание мне дал учитель, я их сам не сочинял. Она просто диктовала и я записывал, вот нужно и составить программу.							
											Похожие вопросы
- Решите информатика 7 класс
- Задачки по информатике, 7 класс. Python.
- помогите ответить на вопросы, информатика 7 класс
- Помогите с информатикой 7 класс.
- Помогите пожалуйста Информатика 7 класс
- Информатика 7 класс ответ писать с обьяснением
- Информатика 7 класс, срочно
- Информатика 7 класс
- Информатика 7 класс помогите
- Информатика 9 класс pascal(mod,div)
