Составить массив из 50 чисел ( от 0 до 100)
1)Найдите число (х- вводимое число) в масиве
2)Найдите максимальное и минимальное число в массиве
3) сдвинуть число на (y-вводимое число)
4) на реверс
	
	
	Домашние задания: Информатика
	
		
		
								
				
								
				
								
				
								
				
			
	
		
			Помогите! Дайте образец решения следущих задач (Паскаль)
Тут только Массив 1) и 2)
var a:array[1..100] of integer;
i,x,min,max:integer;
begin
for i:=1 to 100 do
begin
a[i]:=random(101);
write(a[i],' ')
end;
writeln;
write('x=');
readln(x);
min:=100;
max:=0;
write('x in: ');
for i:=1 to 100 do
begin
if a[i] < min then min:=a[i];
if a[i] > max then max:=a[i];
if a[i]=x then write(i,' ')
end;
writeln;
writeln('min=',min,' max=',max);
end.
				
							var a:array[1..100] of integer;
i,x,min,max:integer;
begin
for i:=1 to 100 do
begin
a[i]:=random(101);
write(a[i],' ')
end;
writeln;
write('x=');
readln(x);
min:=100;
max:=0;
write('x in: ');
for i:=1 to 100 do
begin
if a[i] < min then min:=a[i];
if a[i] > max then max:=a[i];
if a[i]=x then write(i,' ')
end;
writeln;
writeln('min=',min,' max=',max);
end.
Решебник. ру
Надо учиться, а не валоёбить
				
							Надо учиться, а не валоёбить
program Markin2;
var
a: array[0..49] of integer;
x, y, min, max, stakan: integer;
begin
randomize;
for var i:= 0 to 49 do
a[i] := random(100);
writeln('Исходный массив: ', a);
// 1)
write('Число для поиска: ');
readln(x);
for var i:= 0 to 49 do
if a[i] = x then
writeln('Это число ', i+1, '-е в массиве');
// 2)
min := 100;
max := 0;
for var i:= 0 to 49 do begin
if a[i] < min then
min := a[i];
if a[i] > max then
max := a[i];
end;
writeln('Минимальное число в массиве: ', min);
writeln('Максимальное число в массиве: ', max);
// 3)
write('Сдвинуть откуда и куда (позиции через пробел): ');
read(x, y);
for var i:= x-1 to y-2 do begin
stakan := a[i];
a[i] := a[i+1];
a[i+1] := stakan;
end;
writeln('Массив после сдвига: ', a);
// 4)
for var i:= 0 to 24 do begin
stakan := a[i];
a[i] := a[49-i];
a[49-i] := stakan;
end;
writeln('Реверсивный массив: ', a);
end.
				
									var
a: array[0..49] of integer;
x, y, min, max, stakan: integer;
begin
randomize;
for var i:= 0 to 49 do
a[i] := random(100);
writeln('Исходный массив: ', a);
// 1)
write('Число для поиска: ');
readln(x);
for var i:= 0 to 49 do
if a[i] = x then
writeln('Это число ', i+1, '-е в массиве');
// 2)
min := 100;
max := 0;
for var i:= 0 to 49 do begin
if a[i] < min then
min := a[i];
if a[i] > max then
max := a[i];
end;
writeln('Минимальное число в массиве: ', min);
writeln('Максимальное число в массиве: ', max);
// 3)
write('Сдвинуть откуда и куда (позиции через пробел): ');
read(x, y);
for var i:= x-1 to y-2 do begin
stakan := a[i];
a[i] := a[i+1];
a[i+1] := stakan;
end;
writeln('Массив после сдвига: ', a);
// 4)
for var i:= 0 to 24 do begin
stakan := a[i];
a[i] := a[49-i];
a[49-i] := stakan;
end;
writeln('Реверсивный массив: ', a);
end.
Var
x: Array [1..100] of Integer;
i,n,l: Integer;
BEGIN
Write('Введите кол-во элементов: ');
Readln(n);
Write('Введите число L: ');
Readln(l);
Writeln('Введите элементы: ');
For i:=1 to n do
Readln(x[i]);
Writeln('Исходный массив:');
For i:=1 to n do
Write(x[i],' ');
Writeln;
Writeln('Полученный:');
For i:=1 to n do
begin
If x[i]>l Then
x[i]:=100;
Write(x[i],' ');
end;
END.
				
							x: Array [1..100] of Integer;
i,n,l: Integer;
BEGIN
Write('Введите кол-во элементов: ');
Readln(n);
Write('Введите число L: ');
Readln(l);
Writeln('Введите элементы: ');
For i:=1 to n do
Readln(x[i]);
Writeln('Исходный массив:');
For i:=1 to n do
Write(x[i],' ');
Writeln;
Writeln('Полученный:');
For i:=1 to n do
begin
If x[i]>l Then
x[i]:=100;
Write(x[i],' ');
end;
END.
Похожие вопросы
- Помогите пожалуйста нужно написать программу в паскале.
- Помогите с информатикой срочно! блок схемы, паскаль
- Информатика задача паскаль
- Напишите код программы для решения данной задачи.
- Задача по программированию на любом языке, желательно на питоне или паскале. Хватит даже просто алгоритма решения
- Прошу помочь с двумя сложными задачами по "Рекурсивным Алгоритмам" по информатике 9 класс, нужно с решением
- Написать программы с помощью паскаля. Срочно помогите!
- Помогите с дз по информатике. Паскаль. 9 класс.
- Помогите с задачей на паскале
- Информатика, решение задач
 
			 
						 
						 
						 
						
Число для поиска: 1
Это число 46-е в массиве
Минимальное число в массиве: 1
Максимальное число в массиве: 99
Сдвинуть откуда и куда (позиции через пробел): 2 5
Массив после сдвига: [62,97,60,16,99,40,22,70,81,36,45,62,56,72,26,51,14,99,84,71,97,26,12,69,71,43,69,23,4,92,46,67,43,33,96,27,21,8,36,91,4,85,57,80,23,1,77,84,46,83]
Реверсивный массив: [83,46,84,77,1,23,80,57,85,4,91,36,8,21,27,96,33,43,67,46,92,4,23,69,43,71,69,12,26,97,71,84,99,14,51,26,72,56,62,45,36,81,70,22,40,99,16,60,97,62]