Домашние задания: Информатика
Написать программу определения истинности высказывания о равностороннем треугольнике
Программа Информатики 8-го класса прям срочно надо помогите пожалуйста
Программу, значит, написать... - Это можно. Только вот на каком языке программирования это нужно сделать? - Нет, программе-то, конечно, без разницы, на каком языке программирования (а их (языков программирования) существует порядка 40) она написана, а вот учитель/преподаватель может спросить, с чего это программа была написана на этом языке программирования, а не на том, который он(а) преподает.
Вот, например, на Pascal:
Вот, например, на Pascal:
Program P1;
uses crt;
var a, b, c: real;
begin
clrscr;
writeln ('Введите с клавиатуры значения сторон треугольника (только числа). После ввода каждой из сторон треугольника нажимайте клавишу Enter. При вводе дробных значений целую часть от дробной отделяйте точкой, а не запятой.');
write ('Введите 1-ую сторону треугольника: ');
readln (a);
write ('Введите 2-ую сторону треугольника: ');
readln (b);
write ('Введите 3-ю сторону треугольника: ');
readln (c);
if (a=b) and (b=c) then writeln ('Ответ: Треугольник является равносторонним.') else writeln ('Ответ: Треугольник не является равносторонним.');
write ('Программа завершена. Для выхода нажмите клавишу Enter.');
readkey;
end.
Вот на Python: print ("Введите с клавиатуры значения сторон треугольника (только числа). После ввода каждой из сторон треугольника нажимайте клавишу Enter. При вводе дробных значений целую часть от дробной отделяйте точкой, а не запятой.")
a=float (input (f"Введите 1-ую сторону треугольника: "))
b=float (input (f"Введите 2-ую сторону треугольника: "))
c=float (input (f"Введите 3-ю сторону треугольника: "))
if a==b and b==c:
print (f"Ответ: Треугольник является равносторонним.")
else:
print (f"Ответ: Треугольник не является равносторонним.")
Вот на C++: #include
using namespace std;
int main()
{
setlocale (LC_ALL, "RUS");
double a, b, c;
cout
a = float(input("Введите длину стороны треугольника: "))
if a <= 0:
print("Длина стороны должна быть положительным числом!")
elif a * 3 == a + a + a:
print("Треугольник со стороной", a, "является равносторонним")
else:
print("Треугольник со стороной", a, "не является равносторонним")
if a <= 0:
print("Длина стороны должна быть положительным числом!")
elif a * 3 == a + a + a:
print("Треугольник со стороной", a, "является равносторонним")
else:
print("Треугольник со стороной", a, "не является равносторонним")
Прохор Раскольников
Только впредь проверяй, а не тупо копируй за нейросетью.
Похожие вопросы
- .Написать программу определения истинности высказывания о равностороннем треугольнике
- Напишите программы в PascalABC.
- Срочно Помогите написать программу по задаче (на любом языке программирования)
- 1) Напишите программу для подсчета произведения чисел введённых пользователем.
- Помогите пожалуйста нужно написать программу в паскале.
- Напишите программу которая с помощью цикла For-NEXT выводит на экран рисунок «Крылья»
- Короче, помогите написать программу на языке паскаля где нужно--->
- (Паскаль) Написать программу для вычисления функции y= x+1 при x<6 ; 2*x-1 при x>=0
- Помогите нужно написать программу буду благодарен
- Помогите пожалуйста написать программу на Си (максимально просто по возможности)